UVa993-Product of digits

Product of digits 

For a given non-negative integer number N , find the minimal natural Q such that the product of all digits of Q is equal N .

Input 

The first line of input contains one positive integer number, which is the number of data sets. Each subsequent line contains one data set which consists of one non-negative integer number N (0$ \le$N$ \le$109) .

Output 

For each data set, write one line containing the corresponding natural number Q or `-1' if Q does not exist.

Sample Input 

3 
1 
10 
123456789

Sample Output 

1 
25 
-1
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int n;
int num[10];
int main(){

    int ncase;
    cin >> ncase;
    while(ncase--){
           cin >> n;
           if(n<=1) {
            cout<<n<<endl;
            continue;
           }
           memset(num,0,sizeof num);
           int digit = 9,t = n;
           while(digit>=2){
                while(t%digit==0){
                    num[digit]++;
                    t/=digit;
                }
                digit--;
           }
           if(t>=2) cout<<-1<<endl;
           else{
                //num[1]++;
                for(int i = 2; i <= 9; i++){
                    while(num[i]--){
                        cout<<i;
                    }
                }
                cout<<endl;
           }

    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值