FatMouse's Speed HDU - 1160(dp)

 FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],…, m[n] then it must be the case that

W[m[1]] < W[m[2]] < ... < W[m[n]]

and

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

Sample Input

6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

Sample Output

4
4
5
9
7

题意:最长子序列题,题目给出体重和速度,所以需要先对一个量进行排序,然后剩下的那个量就可以像处理最长子序列那样做了。 值得一提的是该题需要打印路径,最好的方法是用一个数组pre记录路径。Dp是利用之前计算的结果进行递推得到的,因此,每一步的计算都要用到上一步的结。最长上升子序列,就是枚举当前序列的最后一位,然后从前面递推找最优解。

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[1010],pre[1010],ans[1010];
struct node
{
    int w,s,id;//id为初始位置,因为最后要输出,所以需要标记一下
}g[1010];
int cmp(node x,node y)
{
    if(x.w != y.w)
    return x.w < y.w;
    else
    return x.s > y.s;
}
int main()
{
   int i = 1;
   while(~scanf("%d %d",&g[i].w,&g[i].s))
   {
       g[i].id = i;
       dp[i] = 1;
       pre[i] = 0;
       i++;
   }
   int n = i-1;
   sort(g+1,g+n+1,cmp);
   int maxlen = 0;//最长序列长度
   int maxi;//最长序列的最后一个数下标

   dp[1] = 1;
   for(i=1;i<=n;i++)
   {
       for(int j=1;j<i;j++)
       {
            if(g[i].w>g[j].w&&g[i].s<g[j].s&&dp[i]<dp[j]+1)
            {
                dp[i] = dp[j]+1;
                pre[i] = j;
                if(dp[i]>maxlen)
                {
                     maxlen = dp[i];
                     maxi = i;
                }
            }
       }
   }
   int t = maxi;
   i=0;
   while(t!=0)
   {
       ans[i++] = t;
       t = pre[t];
   }
   printf("%d\n",i);
   while(i>0)
   {
       i--;
       printf("%d\n",g[ans[i]].id);
   }
   return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值