动态规划-Greatest Common Increasing Subsequence

题目描述

This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.

输入

Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.

输出

output print L - the length of the greatest common increasing subsequence of both sequences.

样例输入

1

5
1 4 2 5 -12
4
-12 1 2 4

样例输出

2

#include<iostream>
#include<algorithm>
#include<cstring> 
#include<stdio.h>
using namespace std;
int a[510],b[510],dp[510];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
    	int i,j,m,n;
        memset(dp,0,sizeof(dp));
        cin>>n;
        for(int i=1; i<=n; i++)
            scanf("%d",&a[i]);
        cin>>m;
        for(int i=1; i<=m; i++)
            cin>>b[i];
            
        int MAX;
        for(int i=1;i<=n;i++)
        {
            MAX=0;
            for(int j=1;j<=m;j++)
            {
                if(a[i]==b[j])
                    dp[j]=MAX+1;
                if(a[i]>b[j]&&dp[j]>MAX)
                    MAX=dp[j];
            }
        }
        
        MAX=0;
        for(int i=1;i<=m;i++)
        if(dp[i]>MAX)
            MAX=dp[i];
        cout<<MAX<<endl;
        if(t) cout<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值