1023 Have Fun with Numbers (20分)

1023 Have Fun with Numbers (20分)

题目描述

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798

思路

大数乘法模板题
给出一个大数, 判断 ×2 之后是否还由这几个数字组成, Yes?No
然后输出 大数×2

代码

#include <iostream>
#include <vector>

using namespace std;
/**
 * 大数乘法模板题
 * 给出一个大数, 判断 *2 之后是否还由这几个数字组成, Yes?No
 * 然后输出 大数*2
 */

vector<int> mul(vector<int> &A, int b) {
    vector<int> C;
    int t = 0;
    for (int i = 0; i < A.size() || t; i++) {
        if (i < A.size())
            t += A[i] * b;
        C.push_back(t % 10);
        t /= 10;
    }
    while (C.size() > 1 && C.back() == 0) {
        C.pop_back();
    }
    return C;
}

int main() {
    string a;
    vector<int> A;
    int hash[10] = {0};
    bool f = false;
    cin >> a;
    for (int i = a.size() - 1; i >= 0; i--) {
        A.push_back(a[i] - '0');
        hash[a[i] - '0']++;
    }
    auto C = mul(A, 2);
    for (int i : C) {
        hash[i]--;
    }
    for (auto i : hash) {
        if (i != 0) {
            f = true;
            break;
        }
    }
    if (!f) {
        cout << "Yes" << endl;
    } else
        cout << "No" << endl;
    for (int i = C.size() - 1; i >= 0; i--) {
        cout << C[i];
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值