1060 Are They Equal (25分)

1024 Palindromic Number (25分)

题目描述

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10​5
​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10​100​​ , and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line if the two numbers are treated equal, and then the number in the standard form (>0 unless the number is 0); or if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

YES 0.d[1]...d[N]*10^kd[1]NO

Note: Simple chopping is assumed without rounding.

Sample Input 1:
3 12300 12358.9
Sample Output 1:
YES 0.123*10^5
Sample Input 2:
 3 120 128
Sample Output 2:
NO 0.120*10^3 0.128*10^3

题意

给出三个有意义的数字 n, a, b
将a b 转换成小数点后 n 位的科学计数法, 看是否相等
Yes, 输出这个科学计数法
No, 分别输出a b各自的表示方法

思路

一开始没想那么多就写了一个17分的,很简单就找到小数点的位置,模拟出答案即可
但其实还有其他坑点:

  1. 位数超过 n 的。(如样例所示
  2. 位数没有超过n的。(5 1234 1234.5)
  3. 零的各种形式(0 , 0.0 , 0.00等, 需要特判一下)
  4. 负数(这一点并没有好像,加上之后也没有多得分)

代码

#include <iostream>

using namespace std;

/**
 * 给出三个有意义的数字  n, a, b
 * 将a b 转换成小数点后 n 位的科学计数法, 看是否相等
 * Yes, 输出这个科学计数法
 * No, 分别输出a b各自的表示方法
 */
string solve(string s, int n) {
    int cnt = 0;
    // 删除前导0
    while (s[0] == '0') s.erase(s.begin());
    if (s[0] == '.') {
        // 0.XXX now is .XXX
        s.erase(s.begin()); // 去掉.
        while (!s.empty() && s[0] == '0') {
            // 去除小数点后的前导0
            s.erase(s.begin());
            cnt--; // 指数-1
        }
    } else {
        // x.xxx now is x.xxx
        int idx = 0;
        while (idx < s.size() && s[idx] != '.') {
            // 找到小数点的位置idx
            cnt++; // 指数+1
            idx++;
        }
        if (idx < s.size()) s.erase(s.begin() + idx);// 把小数点去掉
    }
    if (s.empty()) {
        // 特判0, 如果此时s已经为空, 说明0 和 小数点后的前导0都已经被去除掉
        // 也就是当前的 s 的数值就是0
        cnt = 0;
    }
    int idx = 0, cur = 0;
    string res;
    while (idx < n) {
        // 现在s已经变成了纯数字,
        // 按照科学计数法将小数点移动即可
        if (cur < s.size()) res += s[cur++];
        else res += "0";
        idx++;
    }
    res = "0." + res + "*10^" + to_string(cnt);
    return res;
}

int main() {
    int n;
    string a, b;
    cin >> n >> a >> b;
    a = solve(a, n);
    b = solve(b, n);
    if (a == b) {
        cout << "YES " << a << endl;
    } else {
        cout << "NO " << a << " " << b << endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值