1051 Pop Sequence (25分)

1024 Palindromic Number (25分)

题目描述

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input :
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output :
YES
NO
NO
YES
NO

题意

一个容量为 M 的栈, 按照1 2 3 4 … N 的顺序入栈, 随机出栈
给你一个出栈序列, 判断这是否是一个栈的可行序列。 YES or NO

思路

用一个vector存出栈顺序,直接模拟这个过程即可
如果中途使用栈容量大于M, 直接NO
如果最后能够执行到vector的最后一个元素,代表能够顺利出栈,YES

代码

#include <iostream>
#include <stack>
#include <vector>

using namespace std;

/**
 * 一个容量为 M 的栈, 按照1 2 3 4 ... N 的顺序入栈, 随机出栈
 * 给你一个出栈序列, 判断这是否是一个栈的可行序列。 YES or NO
 */
int main() {
    int m, n, k;
    cin >> m >> n >> k;
    while (k--) {
        stack<int> s;
        vector<int> v;
        int cur = 1;
        v.push_back(0);
        for (int i = 1; i <= n; i++) {
            int x;
            cin >> x;
            v.push_back(x);
        }
        for (int i = 1; i <= n; ++i) {
            s.push(i);
            if (s.size() > m) break; // 超过M
            while (!s.empty() && s.top() == v[cur]) {
                // 出栈: 栈顶 和 出栈顺序中当前 相等.
                s.pop();
                cur++;
            }
        }
        if (cur == n + 1) {
            cout << "YES" << endl;
        } else { cout << "NO" << endl; }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值