Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
If no such path exist, you should output impossible on a single line.
Sample Input
3 1 1 2 3 4 3
Sample Output
Scenario #1: A1 Scenario #2: impossible Scenario #3: A1B3C1A2B4C2A3B1C3A4B2C4
国际象棋中马的走法,比较棘手的是题目要求输出路径,并且是按照字典序,故需要从第一个格开始。
AC代码:
#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
using namespace std;
struct node
{
/* data */
int row;
char col;
};
int p, q, x, y;
bool map['Z' + 1][27];
void path(int i, int j, int num)
{
switch(num) {
case 1: {
x = i - 1;
y = j - 2;
break;
}
case 2: {
x = i + 1;
y = j - 2;
break;
}
case 3: {
x = i - 2;
y = j - 1;
break;
}
case 4: {
x = i + 2;
y = j - 1;
break;
}
case 5: {
x = i - 2;
y = j + 1;
break;
}
case 6: {
x = i + 2;
y = j + 1;
break;
}
case 7: {
x = i - 1;
y = j + 2;
break;
}
case 8: {
x = i + 1;
y = j + 2;
}
}
}
bool dfs(node* a, int i, int j, int step)
{
map[i][j] = true;
a[step].row = i;
a[step].col = j;
if(step == a[0].row) return true;
for(int k = 1; k <= 8; ++k) {
path(i, j, k);
int ii = x, jj = y;
if(!map[ii][jj] && ii >= 1 && ii <= p && jj >= 'A' && jj <= 'A' + q - 1)
if(dfs(a, ii, jj, step + 1)) return true;
}
map[i][j] = false;
return false;
}
int main(int argc, char const *argv[])
{
int n;
cin >> n;
int t = 1;
while(t <= n) {
memset(map, false, sizeof(map));
cin >> p >> q;
if(p == 1 && q == 1) {
cout << "Scenario #" << t++ << ":" << endl;
cout << "A1" << endl << endl;
continue;
}
node a[p * q + 1];
a[0].row = p * q;
bool flag = false;
for(int j = 'A'; j <= 'A' + q - 1; ++j) {
for(int i = 1; i <= p; ++i)
if(dfs(a, i, j, 1)) {
cout << "Scenario #" << t++ << ":" << endl;
for(int k = 1; k <= a[0].row; ++k)
cout << a[k].col << a[k].row;
cout << endl << endl;
flag = true;
break;
}
if(flag) break;
}
if(!flag) {
cout << "Scenario #" << t++ << ":" << endl;
cout << "impossible" << endl << endl;
}
}
return 0;
}