POJ1426 Find The Multiple(bfs)

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111


给一个n,让你输出一个n的倍数,且这个数是由0, 1组成的。


由于由0, 1组成,那么这个数能被10或11整除,bfs即可。


AC代码:


#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
using namespace std;
const int MAXN = 1e7 + 5;
typedef long long ll;
int n;
ll q[MAXN];
ll bfs()
{
	int front = 0, rear = 0;
	q[rear++] = 1;
	while(1) {
		ll tmp = q[front++];
		if((tmp * 10) % n == 0) return tmp * 10;
		if((tmp * 10 + 1) % n == 0) return tmp * 10 + 1;
		q[rear++] = tmp * 10;
		q[rear++] = tmp * 10 + 1;
	}
	return -1;
}
int main(int argc, char const *argv[])
{
	while(scanf("%d", &n) != EOF && n) 
		printf("%lld\n", bfs());
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值