You are given n rods of length 1, 2, . . . , n. You have to pick any 3 of them and build a triangle. Howmany distinct triangles can you make? Note that, two triangles will be considered different if they haveat least 1 pair of arms with different length.
Input
The input for each case will have only a single positive integer n (3 ≤ n ≤ 1000000). The end of inputwill be indicated by a case with n < 3. This case should not be processed.
Output
For each test case, print the number of distinct triangles you can make.
Sample Input
5
8
0
Sample Output
3
22
自己公式推错了,可是我测试了好多都没问题,不知道错在哪里。 这题的WA点很奇怪,也很多。。
AC代码:
#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
using namespace std;
const int MAXN = 1000010;
typedef long long ll;
ll dp[MAXN];
int n;
int main(int argc, char const *argv[])
{
for(ll i = 4; i < MAXN; ++i)
dp[i] = dp[i - 1] + ((i - 1) * (i - 2) / 2 - (i - 1) / 2) / 2;
while(cin >> n) {
if(n < 3) break;
cout << dp[n] << endl;
}
return 0;
}
错误代码:求指出错哪了。。
#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
using namespace std;
const int MAXN = 1000002;
typedef long long ll;
ll dp[MAXN] = {0}, a[MAXN], b[MAXN], n;
ll ou(int x)
{
return ((x + 2) * x / 4);
}
ll ji(int x)
{
return ((x + 1) * (x + 1) / 4);
}
int main(int argc, char const *argv[])
{
for(ll j = 2, i = 0; j <= 1000000; ++i, j += 2)
a[i] = ou(j);
for(ll j = 3, i = 0; j <= 1000000; ++i, j += 2)
b[i] = ji(j);
dp[3] = 0;
dp[4] = 1;
int num1 = 0, num2 = 0;
for(ll i = 5; i < 1000001; ++i)
if(i % 2 == 1) dp[i] = dp[i - 1] + a[num1++];
else dp[i] = dp[i - 1] + b[num2++];
while(cin >> n && n > 2)
cout << dp[n] << endl;
return 0;
}