POJ2945 Find the Clones(暴力 & 字典树)

Find the Clones
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 7501 Accepted: 2782

Description

Doubleville, a small town in Texas, was attacked by the aliens. They have abducted some of the residents and taken them to the a spaceship orbiting around earth. After some (quite unpleasant) human experiments, the aliens cloned the victims, and released multiple copies of them back in Doubleville. So now it might happen that there are 6 identical person named Hugh F. Bumblebee: the original person and its 5 copies. The Federal Bureau of Unauthorized Cloning (FBUC) charged you with the task of determining how many copies were made from each person. To help you in your task, FBUC have collected a DNA sample from each person. All copies of the same person have the same DNA sequence, and different people have different sequences (we know that there are no identical twins in the town, this is not an issue).

Input

The input contains several blocks of test cases. Each case begins with a line containing two integers: the number 1 ≤ n ≤ 20000 people, and the length 1 ≤ m ≤ 20 of the DNA sequences. The next n lines contain the DNA sequences: each line contains a sequence of m characters, where each character is either `A', `C', `G' or `T'. 

The input is terminated by a block with n = m = 0 .

Output

For each test case, you have to output n lines, each line containing a single integer. The first line contains the number of different people that were not copied. The second line contains the number of people that were copied only once (i.e., there are two identical copies for each such person.) The third line contains the number of people that are present in three identical copies, and so on: the i -th line contains the number of persons that are present in i identical copies. For example, if there are 11 samples, one of them is from John Smith, and all the others are from copies of Joe Foobar, then you have to print `1' in the first andthe tenth lines, and `0' in all the other lines.

Sample Input

9 6
AAAAAA
ACACAC
GTTTTG
ACACAC
GTTTTG
ACACAC
ACACAC
TCCCCC
TCCCCC
0 0

Sample Output

1
2
0
1
0
0
0
0
0

Hint

Huge input file, 'scanf' recommended to avoid TLE. 


给你n个长度为m的字符串,输出n行,行数代表字符串相同的个数。


AC代码(暴力):


#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
using namespace std;
const int MAXN = 2e4 + 5;
int n, m, a[MAXN];
struct node
{
	/* data */
	char s[25];
}p[MAXN];
bool cmp(node a, node b)
{
	return strcmp(a.s, b.s) <= 0 ? true : false;
}
int main(int argc, char const *argv[])
{
	while(scanf("%d%d", &n, &m) != EOF) {
		if(!n && !m) break;
		for(int i = 0; i < n; ++i) {
			scanf("%s", p[i].s);
			a[i] = 0;
		}
		sort(p, p + n, cmp);
		int cur = 1;
		for(int i = 0; i < n; ++i)
			if(strcmp(p[i].s, p[i + 1].s) == 0) cur++;
			else {
				a[cur]++;
				cur = 1;
			}
		for(int i = 1; i <= n; ++i)
			printf("%d\n", a[i]);
	}
	return 0;
}


AC代码(字典树):


#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
using namespace std;
const int MAXN = 2e4 + 5;
int n, m, hash_table[MAXN];
struct node
{
	/* data */
	int time;
	bool bfind;
	node *next[4];
	node() {
		time = 0;
		bfind = false;
		next[0] = next[1] = next[2] = next[3] = NULL;
	}
};
int get_index(char ch)
{
	switch(ch) {
		case 'A': return 0;
		case 'C': return 1;
		case 'G': return 2;
		case 'T': return 3;
	}
}
void insert(node *pHead, char str[])
{
	int nLen = strlen(str);
	node *p = pHead;
	for(int i = 0; i < nLen; ++i) {
		int index = get_index(str[i]);
		if(p->next[index] == NULL) p->next[index] = new node;
		p = p->next[index];
	}
	if(p->time == 0) hash_table[++p->time]++;
	else {
		hash_table[p->time]--;
		hash_table[++p->time]++;
	}
}
void delete_node(node *pHead)
{
	if(pHead != NULL) 
		for(int i = 0; i < 4; ++i)
			delete_node(pHead->next[i]);
	delete pHead;
}
int main(int argc, char const *argv[])
{
	char tmp[25];
	node *pHead = NULL;
	while(scanf("%d%d", &n, &m) != EOF) {
		if(!n && !m) break;
		pHead = new node;
		for(int i = 0; i < n; ++i) {
			scanf("%s", tmp);
			insert(pHead, tmp);
		}
		for(int i = 1; i <= n; ++i)
			printf("%d\n", hash_table[i]);
		memset(hash_table, 0, sizeof(hash_table));
		delete_node(pHead);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值