hdoj5570balls【求期望】

balls

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 186    Accepted Submission(s): 125


Problem Description
There are  n  balls with  m  colors. The possibility of that the color of the  i -th ball is color  j  is  ai,jai,1+ai,2+...+ai,m . If the number of balls with the  j -th is  x , then you should pay  x2  as the cost. Please calculate the expectation of the cost.
 

Input
Several test cases(about  5 )

For each cases, first come 2 integers,  n,m(1n1000,1m1000)

Then follows  n  lines with  m  numbers  ai,j(1ai100)
 

Output
For each cases, please output the answer with two decimal places.
 

Sample Input
  
  
2 2 1 1 3 5 2 2 4 5 4 2 2 2 2 4 1 4
 

Sample Output
  
  
3.00 2.96 3.20
 

Source
 

参考博客: 点击打开链接
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<list>
#include<queue>
#include<vector>
using namespace std;
const int maxn=1010; 
double p[maxn][maxn];
int main()
{
	int n,m,i,j,k;
	while(scanf("%d%d",&n,&m)!=EOF){
		for(i=0;i<n;++i){
			double sum=0;
			for(j=0;j<m;++j){
				scanf("%lf",&p[i][j]);
				sum+=p[i][j];
			}
			for(j=0;j<m;++j){
				p[i][j]/=sum;
			}
		}
		double ans=0;
		for(j=0;j<m;++j){
			double sum=0;
			for(i=0;i<n;++i){
				sum+=p[i][j];
				ans+=p[i][j];
				ans-=p[i][j]*p[i][j];
			}
			ans+=sum*sum;	
		}
		printf("%.2lf\n",ans);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值