POJ-2406 Power Strings (kmp算法)

Power Strings
Time Limit: 3000MS
Memory Limit: 65536K

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output

For each s you should print the largest n such that s = a^n for some string a.
Sample Input

abcd
aaaa
ababab
.
Sample Output

1
4
3

题意:给出一个字符串,找出一个最小的子串,该子串重复一定的次数便能组成原字符串,最后输出重复的次数。

题解:用KMP算法中的getnext()解题

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N = 1e6+1;
int Next[N];
char p[N];
int getnext() {//next[i]表示i长度的匹配串所拥有的 最长相同前缀后缀 长度
    Next[0] = -1;
    int i = 0, j = -1;//i为pattern串的指针,j为Next数组的指针
    int lenth = strlen(p);
    while (i < lenth) {//没有到pattern的末尾
        if (j == -1 || p[i] == p[j]) {//当前位置匹配
            i++; //移动到下一个位置
            j++;//匹配个数增加
            Next[i] = j;//i位置的匹配数为j
        }
        else j = Next[j];//不匹配就向前回溯
    }
    int left = lenth - j;//left是最小的重复子串长度
    if (lenth%left == 0) 
    return lenth / left;//能整除说明这个最小子串可以重复成当前的串
    else return 1;
}


int main() {
    while (gets(p))
    {
        if (p[0] == '.') break;
        printf("%d\n", getnext());
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值