[最小循环节]Power Strings POJ2406

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题意: 假设s可以由t重复n次拼成,即s=tttt……tt,我们称为s=t^n。先给定一个字符串s,求最大的幂次n使得存在t满足s=t^n。

分析: 最小循环节模板题,复习一下。当s串可以由最小循环节拼成时答案为最小循环节段数,否则答案为1。

具体代码如下: 

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

char s[1000005];
int _next[1000005];

signed main()
{
	while(~scanf("%s", s+1))
	{
		if(!strcmp(s+1, "."))
			break;
		int len = strlen(s+1);
		for(int i = 2, j = 0; i <= len; i++)
		{
			while(j && s[j+1] != s[i])
				j = _next[j];
			if(s[j+1] == s[i])
				j++;
			_next[i] = j;
		}
		int loop = len-_next[len], ans = 1;
		if(len % loop == 0)
			ans = len/loop;
		printf("%d\n", ans);
	} 
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值