HDU-2674 N!Again

N!Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5794    Accepted Submission(s): 3074


Problem Description
WhereIsHeroFrom:             Zty, what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1, N! = N*(N-1)!
 

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
 

Output
For each case, output N! mod 2009
 

Sample Input
 
 
4 5
 

Sample Output
 
 
24 120
 


解答:1.使用同余定理公式:(a*b)mod c=( (a mod c)*(b mod c) )mod c

    2.注意到大于等于2009的阶乘对2009取余结果为0


代码:

#include<iostream>  
#include<queue>
#include<cstdio>  
#include<cstring>  
#include<algorithm> 
#include<vector> 
#include<cmath>  
#include<sstream>
#include<cstdlib>
#include<map>
const int N =1005;
using namespace std;
int main(){
	int n;
	while(scanf("%d",&n)!=EOF){
		if(n>=2009) cout<<"0"<<endl;//大于等于2009的阶乘对2009取余结果为0
		else{
			int sum = 1;
			for(int i =1;i<=n;i++){//同余定理公式(a*b)mod c=( (a mod c)*(b mod c) )mod c
				sum=sum*(i%2009);
				sum=sum%2009;
			}
			cout<<sum<<endl;
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值