POJ - 3463 Sightseeing(最短路和次短路计数)

Sightseeing

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10522 Accepted: 3745

Description

Tour operator Your Personal Holiday organises guided bus trips across the Benelux. Every day the bus moves from one city S to another city F. On this way, the tourists in the bus can see the sights alongside the route travelled. Moreover, the bus makes a number of stops (zero or more) at some beautiful cities, where the tourists get out to see the local sights.

Different groups of tourists may have different preferences for the sights they want to see, and thus for the route to be taken from S to F. Therefore, Your Personal Holiday wants to offer its clients a choice from many different routes. As hotels have been booked in advance, the starting city S and the final city F, though, are fixed. Two routes from S to F are considered different if there is at least one road from a city Ato a city B which is part of one route, but not of the other route.

There is a restriction on the routes that the tourists may choose from. To leave enough time for the sightseeing at the stops (and to avoid using too much fuel), the bus has to take a short route from S to F. It has to be either a route with minimal distance, or a route which is one distance unit longer than the minimal distance. Indeed, by allowing routes that are one distance unit longer, the tourists may have more choice than by restricting them to exactly the minimal routes. This enhances the impression of a personal holiday.

For example, for the above road map, there are two minimal routes from S = 1 to F = 5: 1 → 2 → 5 and 1 → 3 → 5, both of length 6. There is one route that is one distance unit longer: 1 → 3 → 4 → 5, of length 7.

Now, given a (partial) road map of the Benelux and two cities S and F, tour operator Your Personal Holiday likes to know how many different routes it can offer to its clients, under the above restriction on the route length.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with two integers N and M, separated by a single space, with 2 ≤ N ≤ 1,000 and 1 ≤ M ≤ 10, 000: the number of cities and the number of roads in the road map.

  • M lines, each with three integers AB and L, separated by single spaces, with 1 ≤ AB ≤ NA ≠ B and 1 ≤ L ≤ 1,000, describing a road from city A to city B with length L.

    The roads are unidirectional. Hence, if there is a road from A to B, then there is not necessarily also a road from B to A. There may be different roads from a city A to a city B.

  • One line with two integers S and F, separated by a single space, with 1 ≤ SF ≤ N and S ≠ F: the starting city and the final city of the route.

    There will be at least one route from S to F.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of routes of minimal length or one distance unit longer. Test cases are such, that this number is at most 109 = 1,000,000,000.

Sample Input

2
5 8
1 2 3
1 3 2
1 4 5
2 3 1
2 5 3
3 4 2
3 5 4
4 5 3
1 5
5 6
2 3 1
3 2 1
3 1 10
4 5 2
5 2 7
5 2 7
4 1

Sample Output

3
2

Hint

The first test case above corresponds to the picture in the problem description.

dis[x][2]:dis[x][0]表示起点到x的最短路、dis[x][1]表示起点到x的次短路;

cnt[x][2]:cnt[x][0]表示起点到x的最短路条数、cnt[x][1]表示起点到x的次短路的条数;

vis[x][2]对应于x和0、1功能为记录该点是否被访问!

     那么如何更新最小和次小路呢?显然我们容易想到下面的方法:

      1.if(x<最小)更新最小,次小;
      2.else if(x==最小)更新方法数;
      3.else if(x<次小)更新次小;
      4.else if(x==次小)更新方法数;

#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
const int MAXN = 1005;
const int MAXM = 20005;
const int INF = 0x3f3f3f3f;
int head[MAXN],tot;
struct Edge
{
    int to,Next,w;
}edge[MAXM];
void init()
{
    tot = 0;
    memset(head,-1,sizeof(head));
}
void addedge(int u,int v,int w)
{
    edge[tot].to = v;
    edge[tot].w = w;
    edge[tot].Next = head[u];
    head[u] = tot++;
}
bool vis[MAXN][2];
int dis[MAXN][2],cnt[MAXN][2];
struct Node
{
    int u,dis,flag;
    Node(){}
    Node(int _u,int _dis,int _flag)
    {
        u = _u;
        dis = _dis;
        flag = _flag;
    }
    bool operator<(const struct Node& a) const
    {
        return dis > a.dis;
    }
};
void Dijkstra(int s)
{
    struct Node t;
    int u,v,flag;
    memset(dis,INF,sizeof(dis));
    memset(vis,false,sizeof(vis));
    memset(cnt,0,sizeof(cnt));
    dis[s][0] = 0;
    cnt[s][0] = 1;
    priority_queue<Node> pq;
    pq.push(Node(s,dis[s][0],0));
    while(!pq.empty()) {
        t = pq.top();
        pq.pop();
        u = t.u;
        flag = t.flag;
        if(vis[u][flag]) continue;
        vis[u][flag] = true;
        for(int i = head[u]; i != -1; i = edge[i].Next) {
            int w = edge[i].w + t.dis;
            v = edge[i].to;
            //printf("%d\n",v);
            if(w < dis[v][0]) {
                if(dis[v][0] != INF) {
                    dis[v][1] = dis[v][0];
                    cnt[v][1] = cnt[v][0];
                    pq.push(Node(v,dis[v][1],1));
                }
                dis[v][0] = w;
                cnt[v][0] = cnt[u][flag];
                pq.push(Node(v,w,0));
            }
            else if(w == dis[v][0]) {
                cnt[v][0] += cnt[u][flag];
            }
            else if(w == dis[v][1]) {
                cnt[v][1] += cnt[u][flag];
            }
            else if(w < dis[v][1]) {
                dis[v][1] = w;
                cnt[v][1] = cnt[u][flag];
                pq.push(Node(v,dis[v][1],1));
            }
        }
    }
}
int main(void)
{
    int T,u,v,w,n,m,s,e,ans;
    scanf("%d",&T);
    while(T--) {
        init();
        scanf("%d %d",&n,&m);
        while(m--) {
            scanf("%d %d %d",&u,&v,&w);
            addedge(u,v,w);
        }
        scanf("%d %d",&s,&e);
        Dijkstra(s);
        ans = dis[e][0] + 1 == dis[e][1] ? cnt[e][0] + cnt[e][1] : cnt[e][0];
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值