poj 2752

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 
Input
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 
Output
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.
Sample Input
ababcababababcabab
aaaaa
Sample Output
2 4 9 18
1 2 3 4 5


题意概况:简单点说就是找出所给字符串的所有相同的前缀后缀长度。

解题思路:根据题意可以知道最长的相同前缀后缀就是字符串本身,以题中样例ababcababababcabab为例,最大前缀后缀是18,而next[18]=9;也就是说字符串整体的  真  前后缀长度是9,字符串的前9个字符和后9个字符完全一致。现在要找的是比18小的相同前后缀,因为前后两段9个字符串完全一致,那么整体的字符串里面的前后缀和这9个字符串的前后缀是完全一致的,ababcababababcabab小于18的前后缀是ababcabab     ababcabab,而这9个字符ababcabab的前后缀也是一样的。所有再找到整体的前后缀时,可以直接去找前next[i]个字符串的前后缀。

代码:

#include<stdio.h>
#include<string.h>

int next[405000];
int d[405000];
void GetNext(char p[])
{
	
	int i=0;
	int j=-1;
	next[0]=-1;
	int l=strlen(p);
	
	while(i<l)
	{
		if(j==-1||p[i]==p[j])
		{
			i++;
			j++;
			next[i]=j;
		}
		else
		{
			j=next[j];
		}
	}
	/*for(i=0;i<=l;i++)
	{
		printf("%d ",next[i]);
	}
	printf("\n");*/
}
void KMP(char s[])
{

	GetNext(s);
	memset(d,0,sizeof(d));
	int l1=strlen(s);
	int i=l1;
	int t=0;

	while(i<=l1)
	{
		
		d[t]=i;
		t++;
		if(next[i]==0)//必须先判断next[i]是否为0,才能接着找
			break;
		i=next[i];
	}
	for(i=t-1;i>=0;i--)
	{
		printf("%d ",d[i]);
	}
	printf("\n");
}
int main()
{
	char s[405000],p[405000];
	while(gets(s)!=NULL)
	{
		KMP(s);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值