POJ 2752 Seek the Name, Seek the Fame [前后缀相同的KMP]

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

题目大意:给定一个字符串s,从小到大输出s中既是前缀又是后缀的子串的长度。

题解:利用pre数组,首先知道字符串s肯定自己的长度是满足的,其余子串的最后一个字符和S的最后一个字符相同,直到递归到pre[0] = -1 ;

AC代码:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int pre[1000010] , len;
char a[1000010] ;
int b[1000010];
void getpre()
{
    int i = 0 , j = -1 ;
    pre[0] = -1 ;
    while(i<len)
    {
        if(j==-1||a[i]==a[j]) pre[++i] = ++j;
        else j = pre[j];
    }
}

int main()
{
    while(~scanf("%s",a))
    {
        len = strlen(a);
        getpre();
        int ans = 0 ;
        int t = pre[len-1];
        while(t!=-1)
        {
            if(a[t]==a[len-1]) b[ans++] = t+1;
            t = pre[t];
        }
        for(int i = ans -1 ; i>=0 ; i--)
        {
            printf("%d ",b[i]);
        }
        printf("%d\n",len);
    }
    return 0 ;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值