C - POJ 2752 Hash

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

题意:给你一个串,求出既是前缀又是后缀的子串长度。


#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<queue>
#include<cmath>
#include<stack>
using namespace std;
typedef unsigned long long ull;
ull hash[400010], idx[400010], p = 31, mod = 1000000031;
char mapp[400010];
int main()
{
    idx[0] = 1;
    //用来记录p^i;
    for(int i=1; i<=400000; i++)
    {
        idx[i] = idx[i-1]*p%mod;
    }
    while(scanf("%s", mapp+1)!=EOF)
    {
        int len = strlen(mapp+1);
        for(int i=1; i<=len; i++)
        {
            //求出第i个前缀和的hash值,并存在数组hash[i]中;
            hash[i] = (hash[i-1]*p +mapp[i]-'a')%mod;
        }
        for(int i=1; i<=len; i++)
        {
            //先+mod再%mod 是因为在进行这两个操作之前,得到的hash值有可能会出现负数;
            if(  hash[i]==(  (hash[len]-(hash[len-i]*idx[i]%mod))  +mod)%mod  )
                printf("%d ", i);
        }
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值