Find The Multiple
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2 6 19 0
Sample Output
10 100100100100100100 111111111111111111
///虽然看了看题解才知道 答案不会超过 long long 所以step便是数字位数 一但爆了19位就进行其他Dfs
#include <iostream>
using namespace std;
int n;
int flag;
void Dfs(long long m,int step)
{
int mod=m%n;
if (mod==0 && flag==1 && step<=19)
{
cout<<m<<endl;
flag=0;
return ;
}
else if (mod!=0 && flag==1 && step<=19)
{
Dfs(m*10,step+1);
Dfs(m*10+1,step+1);
}
}
int main()
{
while (cin>>n && n)
{
flag=1;
Dfs(1,1);
}
return 0;
}