E - Find The Multiple POJ1426 (有点特殊的搜索)


E - Find The Multiple
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d & %I64u
Submit Status Practice POJ 1426

Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100

111111111111111111



#include<iostream>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<queue>
#include<cstdio>
#include<vector>
#include<algorithm>
#define bug printf("-----\n");
using namespace std;
const int maxn=110;
const int inf=210000;
typedef long long  ll;
int n;
int ok=0;
void dfs(ll k,int dep)
{
    if(ok)return;
    if(k%n==0)
    {
        ok=1;
        cout<<k<<endl;
        return ;
    }
    if(dep>=19)return;//到此返回,__int64的极限
   dfs(k*10,dep+1);
    dfs(k*10+1,dep+1);
}
int main()
{
    //freopen("in.txt","r",stdin);
    int m,i,j,k,t;
    while(cin>>n&&n)
    {
        ok=0;
        dfs(1,0);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值