HDU - 1195 Open the Lock

HDU - 1195

Time Limit: 1000MS Memory Limit: 32768KB 64bit IO Format: %I64d & %I64u

 Status

Description

Now an emergent task for you is to open a password lock. The password is consisted of four digits. Each digit is numbered from 1 to 9. 
Each time, you can add or minus 1 to any digit. When add 1 to '9', the digit will change to be '1' and when minus 1 to '1', the digit will change to be '9'. You can also exchange the digit with its neighbor. Each action will take one step. 

Now your task is to use minimal steps to open the lock. 

Note: The leftmost digit is not the neighbor of the rightmost digit. 
 

Input

The input file begins with an integer T, indicating the number of test cases. 

Each test case begins with a four digit N, indicating the initial state of the password lock. Then followed a line with anotther four dight M, indicating the password which can open the lock. There is one blank line after each test case. 
 

Output

For each test case, print the minimal steps in one line. 
 

Sample Input

    
    
2 1234 2144 1111 9999
 

Sample Output

    
    
2 4
 



#include <queue>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#define N 11
using namespace std;
int vis[N][N][N][N];
typedef struct{
    int step;
    int num[4];
}node;
queue <node> q;
int main()
{
    int T,p;

    scanf("%d", &T);

    while (T--)
    {
        memset(vis,0,sizeof(vis));
        while(!q.empty()) q.pop();
        node start,finish;

        for (int i = 0; i < 4; i++)
            scanf("%1d", &start.num[i]);
        for (int i = 0; i < 4; i++)
            scanf("%1d", &finish.num[i]);

        start.step = 0;
        vis[start.num[0]][start.num[1]][start.num[2]][start.num[3]] = 1;
        q.push(start);
        while(!q.empty())
        {
            node tmp, news;
            tmp = q.front();
            q.pop();
            p = 0;
            for (int i = 0; i < 4; i++)
                if (tmp.num[i] == finish.num[i]) p += 1;
            if (p == 4)
                {
                    printf("%d\n", tmp.step);
                    break;
                }
            for (int i = 0; i < 4; i++) //plus 1
            {
                news = tmp;
                if (tmp.num[i] == 9) news.num[i] = 1;
                else news.num[i] = tmp.num[i] + 1;
                if (vis[news.num[0]][news.num[1]][news.num[2]][news.num[3]] == 0)
                {
                    vis[news.num[0]][news.num[1]][news.num[2]][news.num[3]] = 1;
                    news.step = tmp.step + 1;
                    q.push(news);
                }
            }
            for (int i = 0; i < 4; i++) //minus 1
            {
                news = tmp;
                if (tmp.num[i] == 1) news.num[i] = 9;
                else news.num[i] = tmp.num[i] - 1;
                if (vis[news.num[0]][news.num[1]][news.num[2]][news.num[3]] == 0)
                {
                    vis[news.num[0]][news.num[1]][news.num[2]][news.num[3]] = 1;
                    news.step = tmp.step + 1;
                    q.push(news);
                }
            }
            for (int i = 0; i < 3; i++) //exchange
            {
                news = tmp;
                news.num[i] = tmp.num[i+1];
                news.num[i+1] = tmp.num[i];
                if (vis[news.num[0]][news.num[1]][news.num[2]][news.num[3]] == 0)
                {
                    vis[news.num[0]][news.num[1]][news.num[2]][news.num[3]] = 1;
                    news.step = tmp.step + 1;
                    q.push(news);
                }
            }
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值