【DFS】hdu 5339 Untitled

7 篇文章 0 订阅

Untitled

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1512    Accepted Submission(s): 887


Problem Description
There is an integer a and n integers b1,,bn . After selecting some numbers from b1,,bn in any order, say c1,,cr , we want to make sure that a mod c1 mod c2 mod mod cr=0 (i.e., a will become the remainder divided by ci each time, and at the end, we want a to become 0 ). Please determine the minimum value of r . If the goal cannot be achieved, print 1 instead.
 

Input
The first line contains one integer T5 , which represents the number of testcases.

For each testcase, there are two lines:

1. The first line contains two integers n and a ( 1n20,1a106 ).

2. The second line contains n integers b1,,bn ( 1in,1bi106 ).
 

Output
Print T answers in T lines.
 

Sample Input
  
  
2 2 9 2 7 2 9 6 7
 

Sample Output
  
  
2 -1
 
///AC代码
///题意:一个整数a 和一个数组b
///问你是否能在b中取出r个元素排列组成c数组满足a%c1%c1%…..%cr == 0
///输出最小的r,不能满足条件输出-1

///思路:b按从大到小排序,暴搜

#include <stdio.h>
#include <ctime>
#include <math.h>
#include <limits.h>
#include <complex>
#include <string>
#include <functional>
#include <iterator>
#include <algorithm>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
#include <list>
#include <bitset>
#include <sstream>
#include <iomanip>
#include <fstream>
#include <iostream>
#include <ctime>
#include <cmath>
#include <cstring>
#include <cstdio>
#include <time.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <assert.h>
using namespace std;

int n, a, b[305], ans;
bool cmp(int a, int b)
{
    return a > b;
}

void dfs(int x, int num, int C)  ///(被膜数,数组b下标,数组c下标)
{
    if (x == 0)
    {
        ans = min(ans, C);
        return;
    }
    if (num == n)
    {
        return;
    }

    dfs(x % b[num + 1], num + 1, C + 1);
    dfs(x, num + 1, C);
}


int main()
{
    int t;
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d %d", &n, &a);
        for (int i = 1; i <= n; i++)
        {
            scanf("%d", &b[i]);
        }
        sort(b + 1, b + 1 + n, cmp);

        ans = 500;
        dfs(a, 0, 0);

        if (ans == 500)
        {
            ans = -1;
        }
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值