hdu 5339 Untitled (dfs)

23 篇文章 0 订阅
7 篇文章 0 订阅

Untitled

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1294    Accepted Submission(s): 759


Problem Description
There is an integer  a  and  n  integers  b1,,bn . After selecting some numbers from  b1,,bn  in any order, say  c1,,cr , we want to make sure that  a mod c1 mod c2 mod mod cr=0  (i.e.,  a  will become the remainder divided by  ci  each time, and at the end, we want  a  to become  0 ). Please determine the minimum value of  r . If the goal cannot be achieved, print  1  instead.
 

Input
The first line contains one integer  T5 , which represents the number of testcases. 

For each testcase, there are two lines:

1. The first line contains two integers  n  and  a  ( 1n20,1a106 ).

2. The second line contains  n  integers  b1,,bn  ( 1in,1bi106 ).
 

Output
Print  T  answers in  T  lines.
 

Sample Input
  
  
2 2 9 2 7 2 9 6 7
 

Sample Output
  
  
2

-1

solution:

我们知道一个大数模小数大数会变小,而小数模大数不变,因此我们把b[i]从大到小排序,然后dfs即可

#include<cstdio>
#include<algorithm>
using namespace std;
int b[30],n;
bool cmp(int a, int b)
{
    return a > b;
}
int dfs(int cnt, int pos, int remain)
{
    if (remain == 0)return cnt;
    if (pos >= n)return n + 1;
    int x = dfs(cnt, pos + 1, remain);
    int y = dfs(cnt + 1, pos + 1, remain%b[pos]);
    return min(x, y);
}
int main()
{
    int t,a;
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d%d", &n, &a);
        for (int i = 0; i < n; i++)
            scanf("%d", &b[i]);
        sort(b, b + n,cmp);
        int x = dfs(0, 0, a);
        if (x == n + 1)printf("-1\n");
        else printf("%d\n", x);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值