HPUOJ---2017寒假作业--专题-1/K-Pseudoprime numbers(伪素数)

K - Pseudoprime numbers

 

Fermat's theorem states that for any prime number p and for any integer a > 1, ap =a (mod p). That is, if we raise a to the pth power and divide by p, the remainder isa. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-apseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-apseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input
3 2
10 3
341 2
341 3
1105 2
1105 3
0 0
Sample Output
no
no
yes
no
yes
yes
 
   
思路:(1):p是非素数。
      (2):a的p次方对p取余不等于a.
#include<cstdio>
typedef long long LL;
LL Quick_MI(LL a,LL b,LL c)
{
	int s=1;
	a=a%c;
	while(b)
	{
		if(b&1)
		{
			s=(s*a)%c;
		}
		a=(a*a)%c;
		b=b/2;
	}
	return s;                       //快速幂 
}
typedef long long LL;
LL SS (LL x)
{
	long long i;
	for(i=2;i*i<=x;i++)
	{
		if(x%i==0)
		   return 0;
	}
	return 1;
}                             //素数判断 
int main()
{
	long long p,a,k;
	while(scanf("%lld%lld",&p,&a),p||a)
	{
		k=Quick_MI(a,p,p);
		if((!SS(p))&&k==a)
		{
			printf("yes\n");
		}
		else
		    printf("no\n");
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值