HPUOJ---2017寒假作业--专题0/G-Milk

G - Milk


 
Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest. 

Here are some rules: 
1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive). 
2. Ignatius drinks 200mL milk everyday. 
3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away. 
4. All the milk in the supermarket is just produced today. 

Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it. 
Given some information of milk, your task is to tell Ignatius which milk is the cheapest. 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle. 
Output
For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume. 
Sample Input
2
2
Yili 10 500
Mengniu 20 1000
4
Yili 10 500
Mengniu 20 1000
Guangming 1 199
Yanpai 40 10000
Sample Output
Mengniu
Mengniu

思路:计算单价,即每天喝奶需要花的钱。根据条件,牛奶总体积大于等于1000,直接按喝五天算,那么单价就是总价格除以5,;若小于1000,那么体积除以200,都要是整数,价格除以天数。价格一样的话,按体积算,总体积越大越好。价格可能不是整数,乘以0.1来实现。
#include<cstdio>
#include<algorithm>
using namespace std;
struct Milk
{
	char name[100+11];
	int Y;
	int V;
	double P;//每天喝奶的价格可能不是整数 
 } data[100+11];
 bool cmp(Milk A,Milk B)
 {
 	if(A.P!=B.P)
 	    return A.P<B.P;//每天喝奶需要花的钱数从小到大排,越少越好 
 	else
    {
 		return A.V>B.V;//喝奶花的钱数一样时,总体积从大到小排,越大越好 
	}
 }
 int main()
 {
 	int T,N,i;
 	scanf("%d",&T);
 	while(T--)
 	{
 		scanf("%d",&N);
 		for(i=0;i<N;i++)
 		{
 			scanf("%s%d%d",data[i].name,&data[i].Y,&data[i].V);
 			if(data[i].V>=1000)
 			{
 				data[i].P=data[i].Y/5*1.0;//浮点型的P通过乘以0.1来实现,其他的数据还有整除啥的,不能设为浮点型 
			 }
			 else if(data[i].V>=200&&data[i].V<1000)
			 {
			 	data[i].P=data[i].Y/(data[i].V/200)*1.0;
			 }
			 else if(data[i].V<200)
			{
				data[i].P=10000000;
			}
		 }
		 sort(data,data+N,cmp);
		 printf("%s\n",data[0].name);
	 }
	 return 0;
 }


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值