POJ-3660 cow contest(floyd求传递闭包)



N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ AN; 1 ≤ BN; AB), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2

题意:给出N头牛和M场比赛,每场比赛的胜负结果给出,让你判断其中有多少头牛的名次是确定的。 可以用floyd算法来求传递闭包。  关于传递闭包的内容可以看这里: 点击打开链接  简单来说就是a赢了b,b赢了c,那么a赢了c,最后用一个二重循环来判断,对于任意一头牛,他与其他牛的关系是否是确定的,如果是,那么他的名次就可以确定。注意只有当map[a][b]=0,map[b][a]=0,  他们才是关系不确定的

#include<iostream>
#include<cstring>
using namespace std;

int N, M;
int map[110][110];//map[i][j]表示i赢了j 

int main(){
	while(cin>>N>>M){
		memset(map,0,sizeof(map));
		int a, b;
		for(int i=1;i<=M;i++){
			cin>>a>>b;
			map[a][b]=1;
		}
		for(int k=1;k<=N;k++){
			for(int i=1;i<=N;i++){
				for(int j=1;j<=N;j++){
					if(map[i][k]&&map[k][j])
					    map[i][j]=1;
				}
			}
		}
		int ans=0;
		int j;
		for(int i=1;i<=N;i++){
			for(j=1;j<=N;j++){
				if(i==j) continue;
				if(map[i][j]==0&&map[j][i]==0) break;
			}
			if(j>N) ans++;
		}
		cout<<ans<<endl;
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值