POJ-3660 Cow Contest

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

Source

USACO 2008 January Silver

题意

      有n头牛比赛,m次比赛结果,问你一共有多少头牛的排名可以被确定,其中如果i战胜k,k战胜j,则也可以说i战胜j,即可以传递胜负。

分析
这是一道经典的Floyd算法求传递闭包问题。所谓传递性,可以这样理解:对于一个节点i,如果i能到k,k能到j,那么i就能到j。求传递闭包,就是把图中所有满足这样传递性的节点都求出来,计算完成后,我们也就知道了任意两个节点之间是否相连。

   本题中,如果一头牛被x头牛打败,打败y头牛,且x+y=n-1,则这头牛的排名被确定了。我们首先确定一下任何两头牛的胜负关,再遍历所有牛判断一下是否满足x+y=n-1,将满足这个条件的牛数目加起来就是所求解。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int inf=0x3f3f3f3f;
const int Max_n=110;
int n,m;
int d[Max_n][Max_n];
int main()
{
    scanf("%d%d",&n,&m);
    memset(d,0,sizeof(d));
    int a,b;
    for(int i=1;i<=m;i++){
        scanf("%d%d",&a,&b);
        d[a][b]=1;
    }
    for(int k=1;k<=n;k++) //求出任意两头牛的胜负关系
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++){
                d[i][j]=d[i][j]||(d[i][k]&&d[k][j]);
            }
    int ans=0;
    for(int i=1;i<=n;i++){
        int cnt=0;
        for(int j=1;j<=n;j++)
            if(d[i][j]||d[j][i])cnt++;
        if(cnt==n-1)ans++;
    }
    printf("%d\n",ans);
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值