Poj Asteroids(最小顶点覆盖)

Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17456 Accepted: 9498

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.  

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.  
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2



如果这道题目,不放在训练记划,感觉那里也不像二分图。。。。。

看了讨论才知道,可以吧所有的行和列看成来集合,怪物所在的点,即为链接集合中的两个点的线段。故为最小点覆盖问题(最大匹配)

要尽量的发射子弹,即至少选择一个点来进行所有边的消除。


#include<iostream>
#include<cstring>
#include<cstdio>
bool linkmap[510][510],use[510];
int cropath[510],n,m;
int fi(int u)
{
    for(int i=1;i<=n;i++)
    {
        if(linkmap[u][i]&&!use[i])
        {
            use[i]=1;
            if(cropath[i]==-1||fi(cropath[i]))
            {
                cropath[i]=u;
                return -1;
            }
        }
    }
    return 0;
}
using namespace std;
int main()
{
    int a,b,c,k,i;
    ios::sync_with_stdio(false);
    while(cin>>n>>m)
    {
        memset(linkmap,false,sizeof(linkmap));
        memset(cropath,-1,sizeof(cropath));
        for(i=0;i<m;i++)
        {
            cin>>a>>b;
            linkmap[a][b]=true;
        }
        int ans=0;
        for(i=1;i<=n;i++)
        {
            if(fi(i))
            {
            memset(use,0,sizeof(use));
                ans++;
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值