POJ 1426 Find The Multiple(BFS)

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 22009 Accepted: 9051 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100

111111111111111111

#include<iostream>//此题的答案不维一
#include<cstdio>
#include<cstring>//竟然找一个数的十进制的整数倍还可以这么做
#include<cmath>
#include<queue>
#define LL long long
using namespace std;
LL n,m;
void bfs(LL x)
{
    LL y;
    queue<LL>q;
    while(!q.empty())
    q.pop();
    q.push(x);
    while(!q.empty())
    {
        x=q.front();
        q.pop();
        if(x%n==0)
        {
            printf("%lld\n",x);
            return ;
        }
        for(LL i=0;i<2;i++)
        {
            y=x;
            if(i==0)
            {
                y=y*10+1;
                q.push(y);
            }
            else
            {
                y=y*10;
                q.push(y);

            }
        }

    }
}
int main()
{
    while(~scanf("%lld",&n))
    {
        if(n==0) break;
        bfs(1);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值