poj 1426 Find The Multiple

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111

题意: 给你一个数n,找到一个只含0和1的十进制数,使得该数能被n整除。

分析:

第一种解法: 能整除即m%n = 0. 

因为m只有0和1组成,即可以看作是由 1, 10 ,100, 1000, 100000.。。。组成的。

比如1010 = (1000+10)。

根据同余模定理,1010%n = (1000%n + 10%n)%n.

所以可以先打表 ,是10^0 打到10^100。

然后对于每个余数,我们可以选择加或不加,dfs一下就好。


第二种:

因为数据量较小,可以直接暴力bfs。


#include<iostream>
#include<cstdio>
#include<string.h>
#include<math.h>
#include<string>
#include<map>
#include<set>
#include<vector>
#include<algorithm>
#include<queue>
#include<iomanip>
using namespace std;
const int INF = 0x3f3f3f3f;
const int NINF = 0xc0c0c0c0;

void bfs(int n)
{
    queue<long long> q;
    q.push(1);
    while(!q.empty()){
        long long temp = q.front();
        q.pop();
        if(temp % n == 0){
            cout << temp  << endl;
            break;
        }
        else{
            q.push(temp*10);
            q.push(temp*10+1);
        }
    }
}
int main()
{
    int n;
    while(cin >> n){
        if(n==0) break;
        bfs(n);
    }
}




#include<iostream>
#include<cstdio>
#include<string.h>
#include<math.h>
#include<string>
#include<map>
#include<set>
#include<vector>
#include<algorithm>
#include<queue>
#include<iomanip>
using namespace std;
const int INF = 0x3f3f3f3f;
const int NINF = 0xc0c0c0c0;

int n;
int mod[150];
bool vis[100];
int suma;
bool dfs(int pos)
{
    if(pos == 0) return 0;
    if((suma+mod[pos])%n == 0){
        vis[pos] = 1;
        return 1;
    }
    suma += mod[pos];
    vis[pos] = 1;
    if(dfs(pos-1)){
        return 1;
    }
    suma -= mod[pos];
    vis[pos] = 0;
    if(dfs(pos-1)){
        return 1;
    }
    return 0;
}
int main()
{
    while(cin >> n){
        if(n==0) break;
        memset(vis,0,sizeof(vis));
        mod[1] = 1%n;
        mod[2] = 10%n;
        mod[3] = 100%n;
        for(int i=4;i<150;i++){
            mod[i] = (mod[i-1]*mod[2])%n;   //余数打表
        }
        int flag;
        for(int i=1;i<150;i++){
            suma = 0;
            if(dfs(i)){			// i表示,从1到i判断每个数加或不加。
                flag = i;
                break;
            }
        }
        for(int i=flag;i>0;i--){
            cout << vis[i];
        }
        cout << '\n';
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值