hdu——1081 To The Max

Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
   
   
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

Sample Output
   
   
15
 

Source
 

Recommend
We have carefully selected several similar problems for you:   1024  1025  1080  1074  1059 

求最大子矩阵的和。思路是构造一个数组sum[i][j],表示第j列从第一行开始到第i行的和。有了这个数组,我们可以枚举子矩阵的上下界,然后构造数组array存储上下界确定时的前i列和。然后找到两列,他们的差最大就行了。

#include<stdio.h>
#include<string.h>

int sum[104][104];
int array[104];
int mat[105][105];

int min(int a,int b)
{
return a<b?a:b;
}

int max(int a,int b)
{
return a>b?a:b;
}

int main()
{
int n;
while(~scanf("%d",&n))
{
memset(sum,0,sizeof(sum));
memset(array,0,sizeof(array));
int ans=-0x3f3f3f;
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
{
scanf("%d",&mat[i][j]);
sum[i][j]=mat[i][j]+sum[i-1][j];
}
for(int up=1;up<=n;up++)
for(int down=up;down<=n;down++)
{
for(int i=1;i<=n;i++)
array[i]=array[i-1]+sum[down][i]-sum[up-1][i];
int mins=0;
for(int i=1;i<=n;i++)
{
ans=max(ans,array[i]-mins);
mins=min(mins,array[i]);
}
}
printf("%d\n",ans);
}
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值