POJ1222——EXTENDED LIGHTS OUT

Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right.
POJ1222——EXTENDED LIGHTS OUT - Alex - Alex

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged.
POJ1222——EXTENDED LIGHTS OUT - Alex - Alex

Note:
1. It does not matter what order the buttons are pressed.
2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once.
3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first
four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off.
Write a program to solve the puzzle.

Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.

Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

Source

Greater New York 2002

前两天去旅游了,今天继续学习,收收心~~~
这题和1681一样,都是利用高消来解异或方程组。构造系数矩阵mat[i][j],如果按下i对j有影响,那么就为1,否则是0.
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>

using namespace std;

int free_x[35];
int x[35];
int mat[35][35];

int Gauss(int equ, int var)
{
int free_num,num=0;
int free_index;
int i, j, k;
int max_r;
int col = 0;
for(i = 0;i < var + 1; i++)
x[i] = 0;
for ( k = 0; k < equ && col < var; k++, col++)
{
max_r = k;
for ( i = k+1; i < equ ; i++)
{
if(abs(mat[i][col]) > abs(mat[max_r][col]))
max_r = i;
}
if(max_r != k)
{
for(i = k; i< var + 1; i++)
swap(mat[k][i], mat[max_r][i]);
}
if(mat[k][col] == 0)
{
k--;
free_x[num++]=col;
continue;
}
for(i = k+1; i < equ; i++)//消元
{
if(mat[i][col])
for(j = col; j < var + 1; j++)
mat[i][j] ^= mat[k][j];
}
}
for(i = k; i < equ; i++)
if(mat[i][var])
return -1;
if(k < var)
return var - k;
for(i = var - 1; i >= 0; i--)
{
int temp = mat[i][var];
for(j = i + 1;j < var; j++)
temp ^= x[j] * mat[i][j];
x[i] = temp;
}
return 0;
}

int main()
{
int t, p=1;
scanf("%d", &t);
while(t--)
{
memset(mat, 0, sizeof(mat));
for(int i = 0; i < 5; i++)
for(int j = 0; j < 6; j++)
{
int d = i * 6 + j;
mat[d][d] = 1;
if(i > 0)
mat[(i - 1) * 6 + j][d] = 1;
if(i < 4)
mat[(i + 1) * 6 + j][d] = 1;
if(j > 0)
mat[i * 6 + j - 1][d] = 1;
if(j < 5)
mat[i * 6 + j + 1][d] = 1;
}
for(int i = 0; i < 30; i++)
scanf("%d", &mat[i][30]);
int res = Gauss(30, 30);
printf("PUZZLE #%d\n", p++);
for(int i = 0; i< 5; i++)
{
for(int j = 0 ;j < 5; j++)
printf("%d ", x[i * 6 + j]);
printf("%d\n", x[i * 6 + 5]);
}
}
return 0;
}




Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值