NOJ1538——[1538] K-Submartix

  • 问题描述
  • You are given a matrix consisting of some integer, its size is n*m.
    You should find a minimum area submatrix that the sum of the submatrix (sum of all elements in the submatrix) is not less k.
  • 输入
  • The input contains multiple test cases. Each test case begins with n, m (1 <= n, m <= 250) and k (-10^9 <= k <= 10^9) on line. Next n lines contain m integer each matrix . The input ends once EOF is met.
  • 输出
  • Print a single integer -- the area of the minimum obtained submatrix. If we cannot obtain a matrix of sum is not less k, print -1.
  • 样例输入
  • 4 4 10
    1 2 3 4
    5 6 7 8
    9 10 11 12
    13 14 15 16
    1 3 15
    10 -5 10
    2 2 10
    1 2
    2 3
  • 样例输出
  • 1
    3
    -1
  • 提示
  • 来源
  • wk@NJUPT

   这题就是让你求一个满足矩阵元素和大于等于k,然后面积最小的矩阵,输出最小面积,如果不存在,就输出-1,

我的思路是,想办法把二维的问题化成一维。所以我需要一个数组sum[i][j],表示第j列从第1行到第i行的元素和。

之后我们枚举矩阵的上下界,利用前缀和的思想,另开一维数组array[],存的就是前i列的和,接下来就是去判断,然后求最小值了。

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>

using namespace std;

const int maxn=270;

int sum[maxn][maxn];
int array[maxn];
int mat[maxn][maxn];
int main()
{
int n,m,k;
while(~scanf("%d%d%d",&n,&m,&k))
{
memset(sum,0,sizeof(sum));
array[0]=0;
int area=0x3f3f3f3f;
for(int i=1;i<=n;i++)
for(int j=1;j<=m;j++)
{
scanf("%d",&mat[i][j]);
sum[i][j]=sum[i-1][j]+mat[i][j];
}
for(int up=1;up<=n;up++)
for(int down=up;down<=n;down++)
{
for(int i=1;i<=m;i++)
{
array[i]=array[i-1]+sum[down][i]-sum[up-1][i];
if(array[i]<k)//也算是个剪枝了,之前没写直接TLE
continue;
for(int j=i-1;j>=0;j--)
if(array[i]-array[j]>=k)
{
area=min(area,(i-j)*(down-up+1));
break;
}
}
}
if(area==0x3f3f3f3f)
printf("-1\n");
else
printf("%d\n",area );
}
return 0;
}

哈夫曼编码是一种常用的数据压缩算法,可以将原始数据转换为更短的编码,从而减少存储空间。它的基本思想是:根据字符出现的频率,构建一颗二叉树,使得出现频率高的字符离根节点近,出现频率低的字符离根节点远。然后,对于每个字符,从根节点出发,沿着对应的路径到达该字符所在的叶子节点,记录下路径,作为该字符的编码。 哈夫曼编码的具体实现步骤如下: 1. 统计每个字符在原始数据中出现的频率。 2. 根据字符的频率构建哈夫曼树。构建方法可以采用贪心策略,每次选择出现频率最低的两个字符,将它们作为左右子节点,父节点的权值为两个子节点的权值之和。重复这个过程,直到只剩下一个根节点。 3. 对哈夫曼树进行遍历,记录下每个字符的编码,为了避免编码产生歧义,通常规定左子节点为0,右子节点为1。 4. 将原始数据中的每个字符,用它对应的编码来代替。这一步可以通过哈夫曼树来实现。 5. 将编码后的数据存储起来。此时,由于每个字符的编码长度不同,所以压缩后的数据长度也不同,但总体上来说,压缩效果通常是比较好的。 实现哈夫曼编码的关键在于构建哈夫曼树和计算每个字符的编码。构建哈夫曼树可以采用优先队列来实现,每次从队列中取出两个权值最小的节点,合并成一个节点,再将合并后的节点插入队列中。计算每个字符的编码可以采用递归遍历哈夫曼树的方式,从根节点出发,如果走到了左子节点,则将0添加到编码中,如果走到了右子节点,则将1添加到编码中,直到走到叶子节点为止。 以下是基于C++的代码实现,供参考: ```c++ #include <iostream> #include <queue> #include <string> #include <unordered_map> using namespace std; // 定义哈夫曼树节点的结构体 struct Node { char ch; // 字符 int freq; // 出现频率 Node* left; // 左子节点 Node* right; // 右子节点 Node(char c, int f) : ch(c), freq(f), left(nullptr), right(nullptr) {} }; // 定义哈夫曼树节点的比较函数,用于优先队列的排序 struct cmp { bool operator() (Node* a, Node* b) { return a->freq > b->freq; } }; // 构建哈夫曼树的函数 Node* buildHuffmanTree(unordered_map<char, int> freq) { priority_queue<Node*, vector<Node*>, cmp> pq; for (auto p : freq) { pq.push(new Node(p.first, p.second)); } while (pq.size() > 1) { Node* left = pq.top(); pq.pop(); Node* right = pq.top(); pq.pop(); Node* parent = new Node('$', left->freq + right->freq); parent->left = left; parent->right = right; pq.push(parent); } return pq.top(); } // 遍历哈夫曼树,计算每个字符的编码 void calcHuffmanCode(Node* root, unordered_map<char, string>& code, string cur) { if (!root) return; if (root->ch != '$') { code[root->ch] = cur; } calcHuffmanCode(root->left, code, cur + "0"); calcHuffmanCode(root->right, code, cur + "1"); } // 将原始数据编码成哈夫曼编码 string encode(string s, unordered_map<char, string> code) { string res; for (char c : s) { res += code[c]; } return res; } // 将哈夫曼编码解码成原始数据 string decode(string s, Node* root) { string res; Node* cur = root; for (char c : s) { if (c == '0') { cur = cur->left; } else { cur = cur->right; } if (!cur->left && !cur->right) { res += cur->ch; cur = root; } } return res; } int main() { string s = "abacabad"; unordered_map<char, int> freq; for (char c : s) { freq[c]++; } Node* root = buildHuffmanTree(freq); unordered_map<char, string> code; calcHuffmanCode(root, code, ""); string encoded = encode(s, code); string decoded = decode(encoded, root); cout << "Original string: " << s << endl; cout << "Encoded string: " << encoded << endl; cout << "Decoded string: " << decoded << endl; return 0; } ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值