POJ2195——Going Home

Description

On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man.

Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point.

You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.

Input

There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.

Output

For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.

Sample Input

2 2
.m
H.
5 5
HH..m
.....
.....
.....
mm..H
7 8
...H....
...H....
...H....
mmmHmmmm
...H....
...H....
...H....
0 0

Sample Output

2
10
28

Source

Pacific Northwest 2004

KM算法求最佳匹配,由于地图上没有什么障碍物,而且走法是水平+垂直,所以求距离的时候不需要bfs,直接记录坐标就行了。

#include<queue>
#include<cstdio>
#include<string>
#include<iostream>
#include<algorithm>

using namespace std;

const int maxn=105;
const int inf=0x3f3f3f3f;
char str[maxn][maxn];
bool visx[maxn],visy[maxn];//在增广路中的点
int mark[maxn];
int lx[maxn],ly[maxn];
int slack[maxn];
int nx,ny,n,m;
int mat[maxn][maxn];
struct node
{
	int x,y;
}point1[maxn],point2[maxn];
bool dfs(int x)
{
	visx[x]=1;
	for(int y=1;y<=ny;y++)
	{
		 if(visy[y])  
          continue;
		int temp=lx[x]+ly[y]-mat[x][y];
		if(temp==0)//可行边,在相等子图里
        {
            visy[y]=1;
            if(mark[y]==-1 || dfs(mark[y]))
            {
                mark[y]=x;
                return true;
            }
        }
        else if(slack[y]>temp)
            slack[y]=temp;
    }  
    return false; 
}

int KM()
{
	memset(ly,0,sizeof(ly));
	memset(mark,-1,sizeof(mark));
	for(int x=1;x<=nx;x++)
	{
        lx[x]=-inf;
        for(int i=1;i<=ny;i++)
          if(lx[x]<mat[x][i])
            lx[x]=mat[x][i];
	}
	for(int x=1;x<=nx;x++)
	{
		for(int y=1;y<=ny;y++)
		  slack[y]=inf;
        while(1)
        {
        	memset(visx,0,sizeof(visx));
		    memset(visy,0,sizeof(visy));
		    if(dfs(x))
		      break;
            int d=inf;
            for(int y=1;y<=ny;y++)
              if(!visy[y] && d>slack[y])
                d=slack[y];
            for(int i=1;i<=nx;i++)
              if(visx[i])
                lx[i]-=d;
            for(int i=1;i<=ny;i++)
              if(visy[i])
                ly[i]+=d;
              else
                slack[i]-=d;
        }
	}
	int ans=0;
	for(int i=1;i<=ny;i++)
	  if(mark[i]!=-1)
	    ans+=mat[mark[i]][i];
    return abs(ans);
}

int main()
{
	while(~scanf("%d%d",&n,&m))
	{
		if(n==0 && m==0)
		  break;
		nx=ny=0;
	    for(int i=0;i<n;i++)
	    {
    		scanf("%s",str[i]);
    		for(int j=0;j<m;j++)
    		  if(str[i][j]=='H')
    		  {
    		  	point2[++ny].x=i;
    		  	point2[ny].y=j;
  		      }
  		      else if(str[i][j]=='m')
  		      {
      		  	point1[++nx].x=i;
      		  	point1[nx].y=j;
      		  }
    	}
    	for(int i=1;i<=nx;i++)
    	  for(int j=1;j<=ny;j++)
  	    	mat[i][j]=-abs(point1[i].x-point2[j].x)-abs(point1[i].y-point2[j].y);	
        printf("%d\n",KM());
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值