hdu1242——Rescue

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16592    Accepted Submission(s): 6030


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13
 

Author
CHEN, Xue
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1016  1072  1175  1548  1180

尼玛输出忘了个句号wa了几发

#include<map>
#include<set>
#include<list>
#include<stack>
#include<queue>
#include<vector>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

bool vis[205][205];
char mat[205][205];
const int inf = 0x3f3f3f3f;
int dir[4][2] = { {1, 0}, {-1, 0}, {0, 1}, {0, -1} };
int n, m;

struct node
{
    int x, y;
    int step;
    friend bool operator < (const node a, const node b)
    {
        return a.step > b.step;
    }
};

priority_queue<node> qu;

bool is_legal(int x, int y)
{
    if( x < 0 || y < 0 || x >= n || y >= m || mat[x][y] == '#')
        return false;
    return true;
}

int bfs(int sx, int sy, int ex, int ey)
{
    while( !qu.empty() )
         qu.pop();
    memset( vis, 0 ,sizeof(vis) );
    node temp1, temp2;
    temp1.x = sx;
    temp1.y = sy;
    temp1.step = 0;
    qu.push(temp1);
    vis[sx][sy] = 1;
    while( !qu.empty() )
    {
        temp1 = qu.top();
        qu.pop();
        if(temp1.x == ex && temp1.y == ey)
        {
            return temp1.step;
        }
        for(int i = 0; i < 4; i++)
        {
            temp2.x = temp1.x + dir[i][0];
            temp2.y = temp1.y + dir[i][1];
            if( !is_legal(temp2.x, temp2.y) )
                continue;
            if( vis[temp2.x][temp2.y] )
                continue;
            vis[temp2.x][temp2.y] = 1;
            temp2.step = temp1.step + 1;
            if(mat[temp2.x][temp2.y] == 'x')
                temp2.step++;
            qu.push(temp2);
        }
    }
    return inf;
}

int main()
{
    while(~scanf("%d%d", &n,&m))
    {
        int ex, ey;
        for(int i = 0; i < n; i++)
        {
            scanf("%s", mat[i]);
            for(int j = 0; j < m; j++)
            {
                if(mat[i][j] == 'a')
                {
                    ex = i;
                    ey = j;
                    break;
                }
            }
        }
        int ans = inf;    
        for(int i = 0; i < n; i++)
            for(int j = 0; j < m; j++)
            {
                if(mat[i][j] == 'r')
                {
                	ans = min(ans, bfs(i, j, ex, ey));
                	//break;
                }
            }
        if(ans != inf)
            printf("%d\n", ans);
        else
            printf("Poor ANGEL has to stay in the prison all his life.\n");
    }
    return 0;
}


 
基于SSM框架的智能家政保洁预约系统,是一个旨在提高家政保洁服务预约效率和管理水平的平台。该系统通过集成现代信息技术,为家政公司、家政服务人员和消费者提供了一个便捷的在线预约和管理系统。 系统的主要功能包括: 1. **用户管理**:允许消费者注册、登录,并管理他们的个人资料和预约历史。 2. **家政人员管理**:家政服务人员可以注册并更新自己的个人信息、服务类别和服务时间。 3. **服务预约**:消费者可以浏览不同的家政服务选项,选择合适的服务人员,并在线预约服务。 4. **订单管理**:系统支持订单的创建、跟踪和管理,包括订单的确认、完成和评价。 5. **评价系统**:消费者可以在家政服务完成后对服务进行评价,帮助提高服务质量和透明度。 6. **后台管理**:管理员可以管理用户、家政人员信息、服务类别、预约订单以及处理用户反馈。 系统采用Java语言开发,使用MySQL数据库进行数据存储,通过B/S架构实现用户与服务的在线交互。系统设计考虑了不同用户角色的需求,包括管理员、家政服务人员和普通用户,每个角色都有相应的权限和功能。此外,系统还采用了软件组件化、精化体系结构、分离逻辑和数据等方法,以便于未来的系统升级和维护。 智能家政保洁预约系统通过提供一个集中的平台,不仅方便了消费者的预约和管理,也为家政服务人员提供了一个展示和推广自己服务的机会。同时,系统的后台管理功能为家政公司提供了强大的数据支持和决策辅助,有助于提高服务质量和管理效率。该系统的设计与实现,标志着家政保洁服务向现代化和网络化的转型,为管理决策和控制提供保障,是行业发展中的重要里程碑。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值