POJ3230——Travel

175 篇文章 0 订阅
Travel
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4185 Accepted: 1758

Description

One traveler travels among cities. He has to pay for this while he can get some incomes.

Now there are n cities, and the traveler has m days for traveling. Everyday he may go to another city or stay there and pay some money. When he come to a city ,he can get some money. Even when he stays in the city, he can also get the next day's income. All the incomes may change everyday. The traveler always starts from city 1.

Now is your turn to find the best way for traveling to maximize the total income.

Input

There are multiple cases.

The first line of one case is two positive integers, n and m .n is the number of cities, and m is the number of traveling days. There follows n lines, one line n integers. The j integer in the i line is the expense of traveling from city i to city j. If i equals to j it means the expense of staying in the city.

After an empty line there are m lines, one line has n integers. The j integer in the i line means the income from city j in the i day.

The input is finished with two zeros.
n,m<100.

Output

You must print one line for each case. It is the max income.

Sample Input

3 3
3 1 2
2 3 1
1 3 2

2 4 3
4 3 2
3 4 2

0 0

Sample Output

8

Hint

In the Sample, the traveler can first go to city 2, then city 1, and finish his travel in city 1. The total income is:
-1+4-2+4-1+4=8;

Source


简单dp题,我们用dp[i][j] 表示到第i天,在城市j时的最大收益,所以方程就很容易写出来了


dp[i][j] = max(dp[i-1][k] - mat[k][j] + w[i][j])


#include <map>  
#include <set>  
#include <list>  
#include <stack>  
#include <queue>  
#include <vector>  
#include <cstdio>  
#include <cmath>  
#include <cstring>  
#include <iostream>  
#include <algorithm>  
  
using namespace std;

int dp[105][105];
int mat[105][105];
int w[105][105];

int main()
{
	int n, m;
	while (~scanf("%d%d", &n, &m))
	{
		if (!n && !m)
		{
			break;
		}
		memset ( dp, -0x3f3f3f3f, sizeof(dp) );
		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; j <= n; j++)
			{
				scanf("%d", &mat[i][j]);
			}
		}
		for (int i = 1; i <= m; i++)
		{
			for (int j = 1; j <= n; j++)
			{
				scanf("%d", &w[i][j]);
			}
		}
		dp[0][1] = 0;
		for (int i = 1; i <= n; i++)
		{
			dp[1][i] = dp[0][1] - mat[1][i];
		}
		for (int i = 1; i <= m; i++)
		{
			for (int j = 1; j <= n; j++)
			{
				for (int k = 1; k <= n; k++)
				{
					dp[i][j] = max(dp[i][j], dp[i - 1][k] - mat[k][j] + w[i][j]);
				}
			}
		}
		int ans = 0;
		for (int i = 1; i <= n; i++)
		{
			ans = max(ans, dp[m][i]);
		}
		printf("%d\n", ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值