Fibonacci Again

Problem
DescriptionThere are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output
Print the word “yes” if 3 divide evenly into F(n). Print the word “no” if not.

Sample Input
0
1
2
3
4
5

Sample Output
no
no
yes
no
no
no

#include<stdio.h>
long long  Fibonacci( long long  n )
{
 	long long a=7,b=11;
 	if(n==0)
  		return a;
 	else if(n==1)
  		return b;
 	int i=2,x,y;
 	while(i<=n)
 	{
  		x=a+b;
  		a=b%3;
  		b=x%3;
  		i++;
  		x=x%3;
 	}
	 return x;
}
int main()
{
 	long long  n,f;
 	while(scanf("%lld",&n)!=EOF)
 	{
  		f=Fibonacci(n);
  		if(f%3==0)
   			printf("yes\n");
 		 else 
   			printf("no\n");
 	}
 	return 0;
 } 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值