[HDOJ] 1002 大数加法(坑爹格式

描述

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


第六次尝试的代码(/”≡ _ ≡)/~┴┴

#include <stdio.h>
#include <string.h>
void accumlate(char* a, char* b, char* c, int maxl);
void reverse(char* a, int len);
int toNum(char a);
char toChar(int a);
char num1[2000];
char num2[2000];
char answer[2000];

int main(void) {
    int times, i;
    scanf("%d", &times);
    for(i=0; i<times; i++) {
        memset(num1,0,sizeof(num1));
        memset(num2,0,sizeof(num1));
        memset(answer,0,sizeof(answer));
        scanf("%s", num1);
        scanf("%s", num2);
        int len1 = strlen(num1);
        int len2 = strlen(num2);
        int maxl = len1>len2?len1:len2;
        printf("Case %d:\n",i+1);
        printf("%s + %s = ", num1, num2);
        reverse(num1, len1);
        reverse(num2, len2);
        accumlate(num1,num2,answer,maxl);
        printf("%s", answer);
        //这里的格式, emmmmmm
        i==times-1?printf("\n"):printf("\n\n"); 
    }
    return 0;
}

void reverse(char* a, int len) {
    char temp;
    int i,j;
    for(i=0,j=len-1; i<=j; i++,j--) {
        temp = a[i];
        a[i] = a[j];
        a[j] = temp;
    }
}

int toNum(char a) {
    if(a=='\0')
    return 0;
    return (int)a - 48;
}

char toChar(int a) {
    return (char)(a+48);
}

void accumlate(char* a, char* b, char* c, int maxl) {
    int i, carry=0, temp=0;
    for(i=0; i<maxl+1 ;i++) {
        if(carry==0 && i==maxl) break;
        temp = toNum(a[i])+toNum(b[i])+carry;
        c[i] = toChar(temp%10);
        carry = temp/10;
    }
    reverse(c, strlen(c));
}

心得

  • reverse 的时候没有弄清楚,以后要记住,奇偶两者情况的判定都是i <= j 就是头不能比尾小。
  • 数组全局。
  • 这种应用字符串做应该不是最好,先mark一下。
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值