1012 The Best Rank (25 分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

结尾无空行
Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

结尾无空行

题意:给出三门课的分数,求每个学生在三门课和平均成绩中最高的排名

如果直接用sort,问题在于出现相同分数时排名应该相同。

此时直接统计几个人比他分数高即可。此法的复杂度是O(N^2),基本够用。

由于出现ID,比较适合使用map。map和python的字典差不多,超级好用。

1: map包含头文件map, 使用map<type1, type2> Map; 构造一个映射

2:通过Map[id]=xxx插入或者修改键值对。

3.通过for(auto it=Map.begin(); it!= Map.end(); it++) 遍历所有的map

4: 通过find(id)!=Map.end() 判断是否存在id

#include<iostream>
#include<vector>
#include<map>
using namespace std;
map<string, float[4]> Student;
int N, M;
int Rank(string id, int i) {
    int rank = 1;
    for (auto it = Student.begin(); it != Student.end();it++) {
        if (it->second[i] > Student[id][i]) rank++;
    }
    return rank;
}
int main() {
    cin >> N >> M;
    for (int i = 0; i < N; i++) {
        string id;
        float c, m, e;
        cin >> id >> c >> m >> e;
        Student[id][0] = (c + m + e) / 3;
        Student[id][1] = c;
        Student[id][2] = m;
        Student[id][3] = e;
    }
    string Out[] = { "A","C","M","E" };
    for (int i = 0; i < M; i++) {
        string ID;
        cin >> ID;
        int MinRank = 101;
        int out = 4;
        if (Student.find(ID) == Student.end()) {
            cout << "N/A";
        }
        else {
            for (int j = 0; j < 4; j++) {
                int rank = Rank(ID, j);
                if (rank < MinRank) {
                    out = j;
                    MinRank = rank;
                }
            }
            cout << MinRank << " " << Out[out];
        }
        if (i != M - 1) cout << endl;
    }
}

如果希望获得所有人的排名,应该怎么办?快排+遍历一遍,求出每个人的排名,复杂度是O(NlogN),感觉还是可以的。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值