Sicily 1001 Alphacode

      Sicily 1001  Alphacode

动态规划

一、问题描述

Alice and Bob need to send secret messages to each other and are discussing ways to encode their messages: Alice: "Let's just use a very simple code: We'll assign `A' the code word 1, `B' will be 2, and so on down to `Z' being assigned 26." Bob: "That's a stupid code, Alice. Suppose I send you the word `BEAN' encoded as 25114. You could decode that in many different ways!" Alice: "Sure you could, but what words would you get? Other than `BEAN', you'd get `BEAAD', `YAAD', `YAN', `YKD' and `BEKD'. I think you would be able to figure out the correct decoding. And why would you send me the word `BEAN' anyway?" Bob: "OK, maybe that's a bad example, but I bet you that if you got a string of length 500 there would be tons of different decodings and with that many you would find at least two different ones that would make sense." Alice: "How many different decodings?" Bob: "Jillions!" For some reason, Alice is still unconvinced by Bob's argument, so she requires a program that will determine how many decodings there can be for a given string using her code.

输入格式

Input will consist of multiple input sets. Each set will consist of a single line of digits representing a valid encryption (for example, no line will begin with a 0). There will be no spaces between the digits. An input line of `0' will terminate the input and should not be processed

输出格式

For each input set, output the number of possible decodings for the input string. All answers will be within the range of a long variable.

样例输入

25114
1111111111
3333333333
0

样例输出

6
89
1


二、解决方法
动态规划算法:基本思想与分治法类似,也是将待求解的问题分解为若干个子问题(阶段),按顺序求解子阶段,前一子问题的解,为后一子问题的求解提供了有用的信息。在求解任一子问题时,列出各种可能的局部解,通过决策保留那些有可能达到最优的局部解,丢弃其他局部解。依次解决各子问题,最后一个子问题就是初始问题的解。

    由于动态规划解决的问题多数有重叠子问题这个特点,为减少重复计算,对每一个子问题只解一次,将其不同阶段的不同状态保存在一个二维数组中。

    与分治法最大的差别是:适合于用动态规划法求解的问题,经分解后得到的子问题往往不是互相独立的(即下一个子阶段的求解是建立在上一个子阶段的解的基础上,进行进一步的求解)。



三、代码

<span style="font-family:Microsoft YaHei;font-size:18px;">#include<iostream>
#include<string>
using namespace std;

int main() {
    string temp;
    int a[10000];
    cin >> temp;
    while (temp != "0") {
        a[0] = 1;
        for (int i = 1; i < temp.size(); i++) {
            if (temp[i] == '0') { 
                if (i == 1) {
                   a[i] = a[i-1];     
                } else {
                    a[i] = a[i-2];
                }
            } else {
                if (temp[i-1] == '1'&&temp[i] <= '9'||temp[i-1] == '2'&&temp[i] <= '6') {
                    if (i == 1) {
                        a[i] = a[i-1]+1;
                    } else {
                        a[i] = a[i-1]+a[i-2];
                    }
                } else {
                    a[i] = a[i-1];
                }
            }
        }
        cout << a[temp.size()-1] << endl;
        cin >> temp;
    }
} 
</span>





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值