[Sicily]1001.Alphacode

1001. Alphacode


Constraints

Time Limit: 1 secs, Memory Limit: 32 MB


Description

Alice and Bob need to send secret messages to each other and are discussing ways to encode their messages: Alice: “Let’s just use a very simple code: We’ll assign A' the code word 1,B’ will be 2, and so on down to Z' being assigned 26." Bob: "That's a stupid code, Alice. Suppose I send you the wordBEAN’ encoded as 25114. You could decode that in many different ways!” Alice: “Sure you could, but what words would you get? Other than BEAN', you'd getBEAAD’, YAAD',YAN’, YKD' andBEKD’. I think you would be able to figure out the correct decoding. And why would you send me the word `BEAN’ anyway?” Bob: “OK, maybe that’s a bad example, but I bet you that if you got a string of length 500 there would be tons of different decodings and with that many you would find at least two different ones that would make sense.” Alice: “How many different decodings?” Bob: “Jillions!” For some reason, Alice is still unconvinced by Bob’s argument, so she requires a program that will determine how many decodings there can be for a given string using her code.


Input

Input will consist of multiple input sets. Each set will consist of a single line of digits representing a valid encryption (for example, no line will begin with a 0). There will be no spaces between the digits. An input line of `0’ will terminate the input and should not be processed


Output

For each input set, output the number of possible decodings for the input string. All answers will be within the range of a long variable.


Sample Input

25114
1111111111
3333333333
0


Sample Output

6
89
1


思路:

递推(动态规划):

涉及到子问题的重叠,用动态规划法较好,但不容易理解递推过程。如果当前字符为‘0’,则dp[i]=dp[i-2],如果当前字符不为‘0’,且与前面的数字组合能构成英文字母,那么dp[i]=dp[i-1]+dp[i-2]。当i= 1时另外处理。

#include <iostream>
#include <memory.h>
#include <string>
using namespace std;

int main() {
    string str;
    while (cin >> str && str != "0") {
        int len = str.length();
        int dp[len];
        memset(dp,0,sizeof(dp)); 
        dp[0] = 1;
        for (int index = 1; index < len ; index++){
            if (str[index] == '0') {
                if (index == 1) dp[index] = dp[index-1];
                else dp[index] = dp[index-2];
            }
            else {
                if ((str[index-1] == '1' && str[index] <= '9')|| (str[index-1] == '2' && str[index] <= '6')) {
                    if (index == 1) dp[index] = dp[index-1] + 1;
                    else dp[index] = dp[index-1] + dp[index-2];
                }
                else dp[index] = dp[index-1];
            }
        }
        cout << dp[len-1] << endl;
    }
    return 0;
}
递归:

思路简单但开销较大,运行耗时太长。

#include <iostream>
#include <string>
using namespace std;
int count;

void find_num(string str, int pos) {
    if (str[pos] == '\0') return;
    find_num(str, pos + 1);
    if (str[pos] <= '2' && str[pos+1] <= '6' && str[pos+1] != '\0'){
        count++;
        find_num(str, pos + 2);
    }
}

int main() {
    string str;
    while (cin >> str && str != "0") {
        count = 1;
        find_num(str, 0);
        cout << count << endl;
    }
    return 0;
}
分治法:

子问题不独立,相较于动态规划做了许多不必要的工作.以25114为例:
25114共有几种解码方式,可以取决于它的前缀解码方式数*后缀解码方式数也就是Num(25114)=(Num(251)*Num(14 )。25114从25|114处分开,而中间的子串“51”本身是否是一个编码,而不应该只算分开时的Num(本例中51本身不是编码)。比如22114,22|114如果按照上述算法共有2*3=6种解码方式,但是子串“21”本身可以作为一种编码,那么22114的递归式就该加上这种考虑,变形为:
Num(22114)=Num(221)*Num(14)+Num(22)*1*Num(4)
详见借鉴:http://blog.csdn.net/suxinpaul/article/details/8007162

#include <iostream>
#include <string>
using namespace std;

int num(string str, int start, int end) {
    int len = start + end;
    if (end - start < 0) return 1;
    else if (end - start == 0) {
        if (str[start] == 48) return 0;
        else return 1;
    }
    else {
        int half = len/2;
        if (str[half] == '0' || str[half] > '2' || str[half] == '2' && str[half+1] > '6')
            return num(str, start, half)*num(str, half+1, end);
        else return num(str, start, half)*num(str, half+1, end) + num(str, start, half-1)*1*num(str, half+2, end);
    }
}

int main() {
    string str;
    while (cin >> str && str != "0") {
        cout << num(str, 0, str.length() - 1)<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值