Cheapest Palindrome POJ - 3280 +动态规划

问题:

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet ofN (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M 
Line 2: This line contains exactly M characters which constitute the initial ID string 
Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

题意:有一个由n个小写字母组成的,长度为m的字符串,可以对其通过增加字符或者删除字符来使其变成回文。而增加或者删除字符都有一个花费,求解使该字符串变成回文的最小花费。

思路:分4中情况讨论:假设一个字符串Xx....yY;

1、去掉X,取x....yY回文;

2、去掉Y,取Xx....y回文;

3、在左边加上X,取Xx....yYX回文;

4、在右边加上Y,取YXx....y回文。

方程:dp[i][j] = min{  dp[i+1][j] + {去掉X的代价},dp[i+1][j] + {加上X的代价},dp[i][j-1]+{去掉Y的代价},dp[i][j-1] +{加上Y的代价}};其实我们可以发现,对于一个单独的字符来说,删掉和在对称位置添加相同的新字母的效果是一样的。只要使用花费最少的操作就行。因此最后得出: dp[i][j] = min{  dp[i+1][j] +min{ {去掉X的代价}, {加上X的代价}},dp[i][j-1]+min{ {去掉Y的代价}, {加上Y的代价}}};dp时候还有些注意事项:比如当X和Y字符一样时,则在dp时必须先为x...y的最小代价。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[2100][2100];
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        char s[2100],x[10];
        int a,b,num[200];
        scanf("%s",s);
        for(int i=0; i<n; i++)
        {
            scanf("%s%d%d",x,&a,&b);
            num[x[0]]=min(a,b);//对于一个单独的字符来说,删掉和在对称位置添加相同的新字母的效果
                                //是一样的。只要使用花费最少的操作就行。
        }
        memset(dp,0,sizeof(dp));
        for(int i=m-1; i>=0; i--)//dp[i][j]表示的是第i个字符到第j个字符要成为回文串需要的最小花费,
            for(int j=i+1; j<m; j++)//只需将上一个状态的i+1和j-1选出最小的花费即可;
            {
                dp[i][j]=min(dp[i+1][j]+num[s[i]],dp[i][j-1]+num[s[j]]);
                if(s[i]==s[j])
                    dp[i][j]=min(dp[i][j],dp[i+1][j-1]);
            }
            printf("%d\n",dp[0][m-1]);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值