C - Edge

Edge

题目描述

For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded along lines parallel to its initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts of the rectangle that are separated by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet.
After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming 90 degree turns at equidistant places.

Input

The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The input file terminates immediately after the last test case.

Output

For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300, 420) with the command “300 420 moveto”. The first turn occurs at (310, 420) using the command “310 420 lineto”. Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of “x y lineto” commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget the end point of the edge and finish each test case by the commands stroke and showpage.

You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.

这里写图片描述

Sample Input

V
AVV

Sample Output

300 420 moveto
310 420 lineto
310 430 lineto
stroke
showpage
300 420 moveto
310 420 lineto
310 410 lineto
320 410 lineto
320 420 lineto
stroke
showpage


思路:

题意:给定一个初始的坐标位置(300,420),输入一串以V(逆时针)和A(顺时针)组成的字符串,然后坐标根据字符串的信息移动,横坐标每次移动10,纵坐标每次移动20,每一动一次,就将新的坐标位置信息输出。

坑:

要求输出的内容较多,注意格式
每次需要判断的信息较多,保持逻辑清晰性


代码

#include <stdio.h>
#include <string.h>

#define dx 10
#define dy 10

struct Cor
{
    int x;
    int y;
} cor[1000];

int check(int n);
void moveto(char s, int dir, int n);
void  print(int n);

int main()
{
    char str[100];

    cor[1].x=300,cor[1].y=420;
    cor[2].x=310,cor[2].y=420;

    int i,len;
    int dir;
    while(scanf("%s",str)!=EOF)
    {
        len=strlen(str);

        printf("300 420 moveto\n");
        printf("310 420 lineto\n");

        for(i=0; i<len; i++)
        {
            dir=check(i+2);
            moveto(str[i],dir,i+2);
            print(i+3);
        }

        printf("stroke\n");
        printf("showpage\n");
        getchar();
    }
    return 0;
}

int check(int n)
{
    if(cor[n].y==cor[n-1].y&&cor[n].x>cor[n-1].x)   //水平向右情形
     return 1;
    else if(cor[n].x==cor[n-1].x&&cor[n].y>cor[n-1].y)  //水平向上情形
     return 2;
    else if(cor[n].y==cor[n-1].y&&cor[n].x<cor[n-1].x)  //水平向左情形
     return 3;
    else if(cor[n].x==cor[n-1].x&&cor[n].y<cor[n-1].y)  //水平向下情形
     return 4;
}

void moveto(char s,int dir,int n)
{
    //逆时针部分
    if(s=='V'&&dir==1){
        cor[n+1].x=cor[n].x;
        cor[n+1].y=cor[n].y+dy;
    }

    else if(s=='V'&&dir==2){
        cor[n+1].x=cor[n].x-dx;
        cor[n+1].y=cor[n].y;
    }
    else if(s=='V'&&dir==3){
        cor[n+1].x=cor[n].x;
        cor[n+1].y=cor[n].y-dy;
    }
    else if(s=='V'&&dir==4){
        cor[n+1].x=cor[n].x+dx;
        cor[n+1].y=cor[n].y;
    }
    //顺时针部分
    if(s=='A'&&dir==1){
        cor[n+1].x=cor[n].x;
        cor[n+1].y=cor[n].y-dy;
    }

    else if(s=='A'&&dir==2){
        cor[n+1].x=cor[n].x+dx;
        cor[n+1].y=cor[n].y;
    }
    else if(s=='A'&&dir==3){
        cor[n+1].x=cor[n].x;
        cor[n+1].y=cor[n].y+dy;
    }
    else if(s=='A'&&dir==4){
        cor[n+1].x=cor[n].x-dx;
        cor[n+1].y=cor[n].y;
    }
}

void print(int n)
{
    printf("%d %d lineto\n",cor[n].x,cor[n].y);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值