F - 最长公共子序列

F - 最长公共子序列

题目描述

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Iutput

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab
programming contest
abcd mnp

Sample Output

4
2
0


思路:

http://blog.csdn.net/hrn1216/article/details/51534607
学算法时没整明白,这位仁兄讲的很清楚了;


代码

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
using namespace std;
#define maxn 500
int main()
{
    int i,j;
    int lenA,lenB;
    int table[maxn][maxn];
    char A[maxn],B[maxn];
    while(scanf("%s%s",A,B)!=EOF)
    {
        //初始化记录表
        lenA=strlen(A);
        lenB=strlen(B);
        for(i=0; i<=lenA; i++)
            table[0][i]=0;
        for(i=0; i<=lenB; i++)
            table[i][0]=0;

        for(i=1; i<=lenB; i++)
        {
            for(j=1; j<=lenA; j++)
            {
                if(B[i-1]==A[j-1])//动规方式
                    table[i][j]=table[i-1][j-1]+1;
                else
                {
                    if(table[i-1][j]>=table[i][j-1])
                        table[i][j]=table[i-1][j];
                    else table[i][j]=table[i][j-1];
                }
            }
        }
        printf("%d\n",table[lenB][lenA]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值