Common Subsequence (POJ1458) dp

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab
programming contest
abcd mnp

Sample Output

4
2
0

题解
简单题意:最大 公共 子序列
dp思路:
先想好边界,任意一字串为0则答案为0
再想状态,每个位置a[0-i][0-j] 都有对应答案
思考化成小问题,思考递推
遇到相同的,则之前的加1
遇到不同的,则必是取之前的
看代码

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;

char str1[1010] = {0,};
char str2[1010] = {0,};
int maxlen[1010][1010] = {0,};

int main()
{
	while(cin >> str1 >> str2)
	{
		int length1 = strlen(str1);
		int length2 = strlen(str2);
		
		//初始化边界 
		for(int i = 0; i <= length1; i++)
			maxlen[i][0] = 0;
		for(int j = 0; j <= length2; j++)
			maxlen[0][j] = 0;
		
		//在str1和str2中挨个对比,在maxlen状态二维表里记录每个位置最大值 
		for(int i = 1; i <= length1; i++)
			for(int j = 1; j <= length2; j++)
				if(str1[i - 1] == str2[j - 1])
					maxlen[i][j] = maxlen[i - 1][j - 1] + 1;
				else
					maxlen[i][j] = max(maxlen[i - 1][j], maxlen[i][j - 1]);
		
		cout << maxlen[length1][length2] << endl;
	}

	return 0;
}


这边我是习惯在定义数组时候就会初始化数组,所以主函数里的边界初始化就算去掉也是可以的,这边写上方便理解

550

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值