Quad Tiling

Description

Tired of the Tri Tiling game finally, Michael turns to a more challengeable game, Quad Tiling:

In how many ways can you tile a 4 × N (1 ≤ N ≤ 109) rectangle with 2 × 1 dominoes? For the answer would be very big, output the answer modulo M (0 < M ≤ 105).

Input

Input consists of several test cases followed by a line containing double 0. Each test case consists of two integers, N and M, respectively.

Output

For each test case, output the answer modules M.

Sample Input

1 10000
3 10000
5 10000
0 0

Sample Output

1
11
95
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

#define MAX(a,b) ((a)>(b) ? (a):(b))
#define MIN(a,b) ((a)<(b) ? (a):(b))

int M;

struct matrix{
	int n,m,a[5][5];
	matrix() 
	{
		n=0; m=0;
		memset(a,0,sizeof(a));
	}
	matrix operator *(const matrix &b) const
	{
		matrix temp;
		temp.n=n; temp.m=b.m;
		for(int i=0;i<n;i++)
		 for(int j=0;j<b.m;j++)
		  for(int k=0;k<m;k++)
		   temp.a[i][j]=(temp.a[i][j]+a[i][k]*b.a[k][j]%M)%M;
		return temp;
	}
	matrix operator *=(const matrix &b)
	{
		*this=*this*b;
		return *this;
	}
};

matrix modulo(matrix t,int n)
{
	int p=n/2;
	if(n==1) return t;
	matrix q=modulo(t,p);
	matrix temp=q*q;
	if(n%2==1) temp*=t;
	return temp;
}

int main()
{
	int n,s[5][5]={{0,1,0,0,0},{1,1,1,0,1},{0,2,1,0,0},{0,0,0,0,1},{0,1,0,1,0}},c[5]={0,1,0,0,0};
	matrix t,b;
	t.n=5; t.m=5;
	for(int i=0;i<5;i++)
	 for(int j=0;j<5;j++)
	  t.a[i][j]=s[i][j];
	b.n=1; b.m=5;
	for(int i=0;i<5;i++) b.a[0][i]=c[i];
	while(scanf("%d%d",&n,&M)!=EOF&&n&&M)
	{
		matrix ans;
		ans=modulo(t,n);
		ans=b*ans;
		printf("%d\n",ans.a[0][1]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值