Mahjong

本文深入探讨了麻将游戏的多种玩法,包括使用麻将牌或卡片,着重介绍了13张牌版本的游戏规则,详细解释了诸如碰、杠、眼等术语,并提供了一个通过已有的13张牌找出能赢的方法。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Mahjong is a favorite pastime in China. It can be played either with a set of mahjong tiles or a set of mahjong playing cards (sometimes spelled "kards" to distinguish them from the list of standard hands used in American mahjong). One brand of mahjong cards calls these Mhing. Playing cards are often used when travelling, as they take up less space and are lighter than their tile counterparts;however, they are usually of a lower quality. In this article, "tile" will be used to denote both playing cards and tiles.

There are many variations of mahjong. In many places, players often observe one version and are either unaware of other variations or claim that different versions are incorrect. Here, we are using the 13-tile version.

In order to simplify the problem. We only consider 13 tiles of Suit Character (named as each tile represents ten thousand coins, or one hundred strings of one hundred coins):

We use a single integer (1 to 9) to represent a tile (Character 1 to 9) in this problem.

In this simplified problem, consider below melds only(refer to Mahjong - Wikipedia for complete description):

  • Pong, or Pung, is a set of three identical tiles.
    For example: 9 9 9; 7 7 7;
  • Chow is a meld of three suited tiles in sequence.
    For example: 1 2 3; 3 4 5; 7 8 9; 5 6 7;
  • An Eye is the pair, while not a meld (and thus cannot be declared or formed with a discard, except if completing the pair completes the hand), is the final component to the standard hand. It consists of any two identical tiles.
    For example: 1 1; 7 7;

A player wins by creating a standard mahjong hand, which consists of a certain number of melds (four for 13-tile version) and a single Eye.

Your task is to figure out which tile can make you win according to 13 tiles you already have.

Note that you can't have more than 4 tiles with a same number at any time.

Input

Multi cases (no more than 25). Process to the end.

Each case has a single line containing 13 integers, which are tiles you already have.

Output

For each case, output tiles that can make you win in one line(sorted, smaller first), separated by one space. There is always a solution.

Sample Input

1 3 4 4 4 4 5 6 6 7 7 7 8

Sample Output

2


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int a[10],flag;

void dfs(int x,int y)
{
	if(y>1||flag) return;
	if(x==4&&y==1) {
		flag=1;
		return;
	}
	for(int i=1;i<=9;i++) {
		if(a[i]>=2) {
			a[i]-=2;
			dfs(x,y+1);
			a[i]+=2;
		}
		if(a[i]>=3) {
			a[i]-=3;
			dfs(x+1,y);
			a[i]+=3;
		}
		if(i+2<=9&&a[i]>=1&&a[i+1]>=1&&a[i+2]>=1) {
			a[i]-=1; a[i+1]-=1; a[i+2]-=1;
			dfs(x+1,y);
			a[i]+=1; a[i+1]+=1; a[i+2]+=1;
		}
	}
}

int main()
{
	int t;
	while(scanf("%d",&t)!=EOF)
	{
		int i,first=1;
		memset(a,0,sizeof(a));
		a[t]++;
		for(i=0;i<12;i++) scanf("%d",&t),a[t]++;
		for(i=1;i<=9;i++) if(a[i]<4) {
			flag=0;
			a[i]++;
			dfs(0,0);
			if(flag) {
				if(first) first=0;
				else printf(" ");
				printf("%d",i);
			}
			a[i]--;
		}
		printf("\n");
	}
	return 0;
}
心得:深搜时,要注意恢复先前改变的变量。

深搜最好不要返回bool类型

### 麻将AI的研究现状 麻将作为一种复杂的策略游戏,吸引了众多研究人员的关注。近年来,在强化学习领域取得的进步显著推动了麻将AI的发展[^1]。 #### 实现方法概述 目前主流的麻将AI实现方式主要依赖于深度学习和强化学习技术。通过构建神经网络模型来模拟人类玩家决策过程,并利用大量对局数据进行训练优化。具体来说: - 使用卷积神经网络(CNN)处理牌面信息 - 应用循环神经网络(RNN)/长短时记忆(LSTM)捕捉时间序列特征 - 结合Q-learning算法评估不同行动的价值函数 这种方法能够有效提高机器在复杂环境下的适应能力和胜率预测精度[^2]。 ```python import torch.nn as nn class MahjongModel(nn.Module): def __init__(self, input_size=34*4, hidden_dim=1024, output_size=38): super(MahjongModel, self).__init__() self.fc1 = nn.Linear(input_size, hidden_dim) self.relu = nn.ReLU() self.dropout = nn.Dropout(0.5) self.fc2 = nn.Linear(hidden_dim, output_size) def forward(self,x): out = self.fc1(x) out = self.relu(out) out = self.dropout(out) out = self.fc2(out) return out ``` #### 开源项目推荐 对于希望深入了解并实践麻将AI开发的人来说,有几个优秀的开源平台值得探索: - **Tenhou.net**:提供了一个在线竞技场以及API接口用于测试自定义bot性能。 - **Mahjong-Gym**:基于OpenAI Gym框架创建的一个专门针对麻将环境设计的库,支持多种规则变体。 - **Tianji**:由阿里云团队维护的一款高性能分布式强化学习平台,内置了完整的麻将玩法逻辑和支持多agent协同训练的功能[^3]。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值