POJ2478 Farey Sequence

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 1000000). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) —- the number of terms in the Farey sequence Fn.

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

思路很简单,就是个求和。

#include <iostream>
#include <string.h>
using namespace std;
long long int phi[1000001];
int main()
{
    long long int n,sum,i,j;
        for(i=1;i<=1000000;i++)
            phi[i]=i;
        for(i=2;i<=1000000;i++)
            if(phi[i]==i)
                for(j=i;j<=1000000;j+=i)
                    phi[j]=phi[j]-phi[j]/i;
    while(cin>>n)
    {
        if(n==0)
            break;
        sum=0;
        for(int i=2;i<=n;i++)
            sum=sum+phi[i];
        cout<<sum<<endl;
    }
    return 0;
}

开始的时候while放在前面(紧跟在声明后面)的时候,一直超时。改成这个样子就好了。

有个使用memset的写法,在while循环内能过,算法原理都一样。

#include <iostream>
#include <string.h>
using namespace std;
long long int p[1000001];
int main()
{
    long long int n,sum;
    while(cin>>n)
    {
        if(n==0)
            break;
        memset(p,0,sizeof(int));
        for(int i=2;i<=1000000;i++)
        {
            if(p[i]==0)
        {
            for(int j=i;j<=1000000;j=j+i)
            {
                if(p[j]==0)
                    p[j]=j;
                p[j]=p[j]-p[j]/i;
            }
        }
        }
        sum=0;
        for(int i=2;i<=n;i++)
            sum=sum+p[i];
        cout<<sum<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值