杭电1025 LIS+排序

Constructing Roads In JGShining's Kingdom

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23348    Accepted Submission(s): 6677


Problem Description
JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
 

Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
 

Output
For each test case, output the result in the form of sample.
You should tell JGShining what's the maximal number of road(s) can be built.
 

Sample Input
  
  
2 1 2 2 1 3 1 2 2 3 3 1
 

Sample Output
  
  
Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.
Hint
Huge input, scanf is recommended.
 

题意:两边分别是富城市和穷城市,两个城市都是从1开始到2,3,4……n,富城市只有一种资源富,穷城市只有一种资源穷,因此每个穷城市要从对应的富城市获取稀缺的资源,因而要在这两个城市之间修路,要求路不能交叉,求最多能修多少条路。、

思路:DP水题,按穷城市顺序排下序,然后求对应富城市的LIS即可,如果用O(N*N)的算法会超时,因此要用O(N*logN)的。

注意:输出格式 road/roads,还有每个案例后要多输出一个空行。(PS:一想起上次CCPC网络赛因为YES和Yes输出的区别WA到怀疑人生就泪流满面,因此下次做题一定一定要看清输出格式)

AC代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
struct ab
{
    int a;
    int b;
}p[500010];
int n,b[500010];
int cmp(struct ab x,struct ab y)
{
    return x.a<y.a;
}
int search(int num,int low,int high)
{
    int mid;
    while(low<=high)
    {
        mid=(low+high)/2;
        if(num>=b[mid])
            low=mid+1;
        else
            high=mid-1;
    }
    return low;
}
int main()
{
    int pos,len,t=1;
    //freopen("D://in.txt", "r", stdin);
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
            scanf("%d %d",&p[i].a,&p[i].b);
        sort(p+1,p+n+1,cmp);
        b[1]=p[1].b;
        len=1;
        for(int i=2;i<=n;i++)
        {
            if(p[i].b>=b[len])
                b[++len]=p[i].b;
            else
            {
                pos=search(p[i].b,1,len);
                b[pos]=p[i].b;
            }
        }
        if(len==1)
            printf("Case %d:\nMy king, at most %d road can be built.\n\n",t++,len);
        else
            printf("Case %d:\nMy king, at most %d roads can be built.\n\n",t++,len);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值