杭电1224 DP+记录路径

Free DIY Tour

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6195    Accepted Submission(s): 1998


Problem Description
Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It's a good chance to relax themselves. To most of them, it's the first time to go abroad so they decide to make a collective tour.

The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company's statistic, each city has its own interesting point. For instance, Paris has its interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number.

Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both 1 and N+1), and its interesting point is always 0.

Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?
 

Input
The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows.
Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map.
Then N integers follows, representing the interesting point list of the cities.
And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi.
 

Output
For each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only one optimal circuit.

Output a blank line between two cases.
 

Sample Input
  
  
2 3 0 70 90 4 1 2 1 3 2 4 3 4 3 0 90 70 4 1 2 1 3 2 4 3 4
 

Sample Output
  
  
CASE 1# points : 90 circuit : 1->3->1 CASE 2# points : 90 circuit : 1->2->1
 

题意:公司成员要组团去旅游,然后旅游公司表示有DIY线路,可以自己选线路去旅游,每个城市都有一定的兴趣点,另外起点在杭州,终点也一定是在杭州,只是中途的城市以及路线要自己DIY,并且不会有从大编号城市到小编号城市的路线。求出这趟旅行最大的兴趣点数并输出路线。
思路:DP不难想,但是记录路径并输出的过程处理起来比较麻烦,这里是采用递归输出,用c[ i ]存储满足题意的到达第 i 个城市的前一个城市。然后DP部分,主要就是用dp[ i ]表示到达第 i 个城市的最大兴趣点数,因此dp[ i ]=max(dp[ i ],dp[ j ] + p[ i ])。

AC代码:
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define LL long long
#define M(x) memset(x,0,sizeof(x))
using namespace std;
int p[110],dp[110],map[110][110],c[110],n;
void print(int s)
{
    if(s==1)
        return;
    print(c[s]);
    printf("->%d",s);
}
int main()
{
    //freopen("D://in.txt", "r", stdin);
    int T,m,a,b;
    scanf("%d",&T);
    for(int t=1;t<=T;t++)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&p[i]);
        p[n+1]=0;
        scanf("%d",&m);
        M(map);
        for(int i=1;i<=m;i++)
        {
            scanf("%d %d",&a,&b);
            map[a][b]=1;
        }
        M(dp);
        M(c);
        int max1=-1,k,x=1;
        for(int i=1;i<=n+1;i++)
        {
            for(int j=1;j<i;j++)
            {
                if(dp[j]+p[i]>dp[i]&&map[j][i])
                {
                    dp[i]=dp[j]+p[i];
                    c[i]=j;
                }
            }
        }
        printf("CASE %d#\npoints : %d\ncircuit : %d",t,dp[n+1],1);
        print(c[n+1]);
        printf("->1\n");
        if(t!=T)
            printf("\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值